Everything related to the integration for SketchUp.
By Mike Amos 20170711101533
#396289
OK, the One way mirror does not render as a mirror in sketchup 2017 it appears to be missing from the render and is completely clear. I have grouped the mirrors but no matter what I try this happens. PITA. Trying sketchup 2016. No, the same in sketchup 2016. :shock:
By JDHill
#396293
Without knowing how you are attempting to create whatever it is you are referring to (i.e. geometry & materials), it is not possible to say much. Regardless, I can say that in the physical sense, there is no such thing as a one-way mirror; mirrors that are commonly called that are, in reality, just mirrors that are only partially-reflective. Such a mirror can act as a "one-way" mirror, provided that the environment on one side of it is significantly more brightly-lit than the other; to use the common example of an interrogation room, as seen in TV & movies, were those on the observer side to switch on the lights in their room, they would immediately become just as visible to those being interrogated, as the latter are, to them.

In Maxwell, ways of creating such a partially-transparent mirror would include using an AGS material with high reflectivity, or a custom material that mixes a mirror BSDF with a "vacuum" BSDF, or applying a mirror material (e.g. could just be a silver metal) to an object, and then making the object semi-transparent by means of the Opacity object property.
By Mike Amos 20170711101533
#396294
I have a flat plane set as a group within a wardrobe, which is a component. This material is an mxm from the resources page.

This material worked last year but not this year. I have tried sketchup 2016 and 2017, I will not be getting sketchup 2018.

To be clear, the problem is that now the mxm is completely clear and acts like the group is missing so I can see the interior of the wardrobe and the wall behind it.

PS. I know what the item known as a two way mirror is and how it works but thanks anyway.
By JDHill
#396296
Please don't be offended that I would explain one-way mirrors; I try to answer as completely as I can, given the information provided, if only because more people than just you will read this.

Now, given the additional information you have provided, I can first say that it is unlikely for this to have to do with the SketchUp version, because that would require a change in behavior either in how geometry works in SketchUp, or material assignment. Next, it is likewise unlikely to have to do with the plugin, for similar reasons. And last, it is unlikely to be due to the MXM file itself, provided the file in question has not been changed.

This leaves two main possibilities: a) the material is not being assigned how you think it is, or b) the MXM file is not being found.

In either case, my initial troubleshooting advice would be the same: edit the material in the plugin, changing it from linking to an MXM, to using an embedded material Character. This is to rule out any possibility of the issue pertaining to the MXM. Next, I would edit the material Character to be something visually obvious -- a diffuse magenta color, or similar. Once you successfully use this obvious material to confirm that the material is being assigned as intended, in this particular case, I would then forgo the use of an MXM, and instead switch to using the Metal Character, set to the Mirror preset. Lastly, if you want the object to be semi-transparent, I would open the Object Properties window, select the geometry, and set Opacity to something less than 100%.
By Mike Amos 20170711101533
#396309
Sorry, no offence taken and no need to appologise. If not for your responses I would learn very little.

Looking into your pointers and I will get back to you with what I find.

So far my only option was to ungroup (my group wa[…]

Thanks Miguel I know 5.2+ is a big development hi[…]

SketchUp 2021 Update

Hi Alberto, Many thanks for taking the time to ma[…]

Let's talk about Maxwell 5.2

Features are closed and tested, we are testing p[…]