Everything related to the integration for SketchUp.
By mpoole1
#395771
I have installed Maxwell 4 for Sketchup, with a floating license. If I install it and the license server on my local machine everything works fine. As soon as I install the Maxwell Studio 4 on the same machine, and it floating license the Sketchup plugin stops working.

I uninstalled everything and reinstalled Maxwell Studio 4 and the License manage on a different machine, everything on that machine works well. Maxwell render is working well on both machines, except the Sketchup Plugin gives the following error everytime I try and use Maxwell for Sketchup.

MX: Failed to check out license:
Product: maxwell_bundle [gui]
Information: originally requested [gui] license for [maxwell_sketchup]
Request Status: -18 [License server does not support this product]
Manager Status: No error
License Status: No error
Host ID: d067e539e549
License Path: [none] [requestLicense (1) failed] [broadcast]
Path [override]: [empty]
Path [product]: C:\ProgramData\Next Limit\Maxwell\licenses\maxwell_bundle.lic [file not found]
Path [environment]: C:\ProgramData\Next Limit\Maxwell\licenses\maxwell_bundle.lic [duplicate path]
Path [automatic]: C:\ProgramData\Next Limit\Maxwell\licenses\maxwell_license.lic [requestLicense (1) failed]Failed to check out license:
Product: maxwell_sketchup [gui]
Information: originally requested [gui] license for [maxwell_sketchup]
Request Status: -18 [License server does not support this product]
Manager Status: No error
License Status: No error
Host ID: d067e539e549
License Path: [none] [requestLicense (1) failed] [broadcast]
Path [override]: [empty]
Path [product]: C:\ProgramData\Next Limit\Maxwell\licenses\maxwell_sketchup.lic [file not found]
Path [environment]: C:\ProgramData\Next Limit\Maxwell\licenses\maxwell_sketchup.lic [duplicate path]
Path [automatic]: C:\ProgramData\Next Limit\Maxwell\licenses\maxwell_license.lic [requestLicense (1) failed]
Failed to check out license:
Product: maxwell_bundle [gui]
Information: originally requested [gui] license for [maxwell_sketchup]
Request Status: -18 [License server does not support this product]
Manager Status: No error
License Status: No error
Host ID: d067e539e549
License Path: [none] [requestLicense (1) failed] [broadcast]
Path [override]: [empty]
Path [product]: C:\ProgramData\Next Limit\Maxwell\licenses\maxwell_bundle.lic [file not found]
Path [environment]: C:\ProgramData\Next Limit\Maxwell\licenses\maxwell_bundle.lic [duplicate path]
Path [automatic]: C:\ProgramData\Next Limit\Maxwell\licenses\maxwell_license.lic [requestLicense (1) failed]
By JDHill
#395772
I believe the main clue is that "license server does not support this product" message, indicating that there is a license (or licenses) available, but that it's not for sketchup. In my own case, I have several different floating .lic files in the C:\ProgramData\Next Limit\Maxwell\licenses directory, for studio and various plugins, and everything works fine.

So I can only recommend checking that you have a "maxwell_license.lic" file, with "HOST localhost ANY 5053" in it (or similar), along with "maxwell_sketchup_floating.lic" and "maxwell_studio_floating.lic" files, with the actual sketchup/studio license data in them.

If this information does not help, please contact support via your portal account at https://portal.nextlimit.com, as I am not an authority on this subject.
By mpoole1
#395775
Thanks JD. I have 3 License files in the C:\ProgramData\Next Limit\Maxwell\licenses, on the machine that has the license manager, but on one on the work station that is trying to check out the floating sketchup license. Do you know if the license files need to be on both machines in order to be checked out?
By JDHill
#395778
On the workstation, there should only be maxwell_license.lic, with the IP address of the license server machine. It should be written by the license activator, when you choose the "I have installed the server on a different computer" option, which prompts you to enter the IP (or host name) of the license server machine.
By mpoole1
#395787
JD,

Thank you for your help. I think we have it all worked out. Maxwell 4.0 was running great, but it was on one local machine. We had not setup any render nodes, or studio. When, we went to set the 4.1 license manager up over the network, was when the problem started. It's my mistake. Out IT group is providing system and security monitor for all our computers. Even though the windows fire wall was down, they had installed additional software and it was blocking the network communications from the license manager to the other computers. I should have checked that with them first. We're getting it worked out now.

Thanks again for your help.

Hi Guys... Just updated Rhino to Maxwell plugin V[…]

SketchUp 2021 Update

Hi there! Sorry, it is the obligatory post relat[…]

Keep in mind that AVAST actually block anything re[…]

Maxwell and Blender

Thanks for looking into this - hopefully you get w[…]