User avatar
By dk2079
#388412
Hi

sorry to bug you again, but I get strange error messages on the command line with grass.
Just tried fresh scene: make plane, like 1m², make grass extension, assign, render to fire.
I just noticed it, basically FIRE stalls for some seconds (depends on the number of grass) and then plots lines like in the end of this command line output, sometimes it is thousands of lines making things very slow.
rendering to maxwell works, debug does not show any strange lines.
Loading Maxwell for Rhino, version 3.1.5.0, 16.08.2015 17:20:08
Command: 2sf
Command: plane
First corner of plane ( 3Point Vertical Center Deformable ):
Other corner or length ( 3Point ):
1 surface added to selection.
1 surface added to selection.
Maxwell: Assigned selected Extensions to 1 object.
Command: mxf
Command: Maxwell_Render
Choose Option <RenderScene> ( RenderScene RenderSelectedObjects ToFire=No UseViewNameAsOutputName=No ForceNewMeshes=Yes ): t
Choose Option <RenderScene> ( RenderScene RenderSelectedObjects ToFire=Yes UseViewNameAsOutputName=No ForceNewMeshes=Yes ): e
Maxwell: Rendering camera 'Perspective'.
Maxwell: Exporting new data, press Esc to cancel.
Maxwell: Exporting meshes...
Maxwell: Mesh transfer 100,00% completed (1 of 1)
Maxwell: Total export time: 00:00:00.1142622.
Maxwell: Warning => Object is not a instance (caller=getInstanced)
Maxwell: Error => Object is not a instance (caller=getInstanced)
Maxwell: Warning => Object is not a instance (caller=getInstanced)
Maxwell: Error => Object is not a instance (caller=getInstanced)
Maxwell: Warning => Object is not a instance (caller=getInstanced)
Maxwell: Error => Object is not a instance (caller=getInstanced)
By JDHill
#388413
There was a problem with this in the version of maxwellgrass that is used in the plugin (those messages come directly from the grass extension). It should be fixed, but could you please upload a copy of a simple scene that produces this for you, so I can make sure it is working correctly in the next plugin build.
User avatar
By dk2079
#388415
running the plugin 3.1.5.0 I get it just doing:

new scene, meters

make plane

make extension (no changes)

assign

send to FIRE.



strange is, that I just had the problem in a scene where I already had removed all grass extensions.
maybe there was some cached data left, I kept on sending selected objects to fire to find the geometry in charge, but then the error did not show up anymore.

I had some very strong highlights in some material[…]

Daydreamer

Thanks everyone! I didn't want to use volumetrics […]

opening V5 files in v6

just installed latest version for Rhino V6 when I[…]

I hope someone can help me! This is almost certain[…]