All posts related to V2
By prodviz
#374029
Hi all,

I've got a sphere set at 5cm and with 8 subdivs (using display smoothness) - in maya 2014 on the mac.

When I add a maxwell shader with displacement (a rock normal map from the Maxwell folder), the RAM usage starts to head upward and max out the physical RAM at 13GB (there's 16GB installed) and the virtual memory at 33GB. Maya then freezes/starts with the spinny wheel.

Are there tips for working with displacements, where I can reduce the RAM usage?

cheers,

Steve
By RichG
#374033
I find the default setting (at least in Cinema) of 16 is often overkill. Obviously it depends on how tessellated your mesh is before displacement but I always knock it down to 4 at most to start with for fast results and then increase if quality needs it.
User avatar
By Mihai
#374035
Pretess will always be faster, and sometimes MUCH faster than On the fly displacement. In your case, it sounds like the sphere is already subdivided a lot (8 times), so in the displacement settings, set it to pretess and maybe a subdivision of 1 or 2 and see if that's enough.
By prodviz
#374040
Cool, cheers for the info.

Starting with a low pretess subdiv worked well too, without taking the large about of RAM, as before.

However, on adding a new maxwell shader to the same scene, maya has frozen (Not responding) and the processors have gone bonkers.
I've repeated these steps a couple of times.

Cheers,

Steve
User avatar
By Mihnea Balta
#374041
Did you set subdivision to 8 in the Maya smoothing parameters (i.e. the "Smooth Mesh" rollup in the attribute editor for the shape node)? Because that will export a sphere with 12 million triangles to Maxwell, and then Maxwell will further subdivide it for displacement. Turn off smoothing in Maya, it's not needed.
By prodviz
#374044
I set the sphere's subdivs in the channel box, in the initial modeling. So the 8 subdivs appear in the 'polySphere1' node.

I am using smooth mesh, though, but just the default settings of 2.

Is a better approach, to create a sphere with enough ploys to look smooth, but without using the 'smooth mesh'?
User avatar
By Mihnea Balta
#374046
Oh, I see.

In the case of a sphere, setting the number of subdivisions in the generator node offers more control compared to smoothing. However, smoothing has the advantage that you can turn it off in the viewport, so you only use high-poly meshes when you export the scene to Maxwell. The result in the render is the same (a sphere with lots of polygons), so the decision should be made based on how if affects the interactivity of the viewport.

Do you have lots of spheres? If yes, are you instancing them, or making copies?
By prodviz
#374047
Cool, cheers for the info.

As for the spheres, it's just a test scene for displacement with an additional non displaced coating over the top, so now worries on the number of spheres.

Cheers again.

Steve

Hey, yup - the actual pre-order happens in custome[…]

is Maxwell Render abandoned?

New cloud render feature from twitter: https://t[…]

FormZ 9 support

I've been a loyal user of FormZ since v4.86 ( ma[…]

Yes and Solidworks!! Wow Blast from the past Nico![…]