#371050
I'm trying to apply Maxwell materials to faces of a multi-body solidworks part (using the maxwell plugin for solidworks). I can apply the maxterials (with textures) to the faces, then I can map the textures with Solidwork's 'texture mapping tool'. This all looks great in the viewport of Solidworks. However, when I export to Maxwell studio the textures aren't mapped correctly / according to the settings I've just applied in Solidworks. Sometimes a material just disappears on going into studio mode and sometimes a material is assigned to a completely different body.

I'm having great difficulties with applying textures and getting them to render correcly. Is there a general workflow I should be using with textures and the maxwell plugin?

Here's a screenshot to show what I mean. (on the right is the 'Maxwell Fire' result)

Image
#371054
The preferred workflow at the moment is to export an MXS to Maxwell Studio and do texturing there, because while SW provides UV coordinates for meshes, they are not those created when using the SW texture-mapping tools, but rather the older-style non-RealView ones, defined using just a single rotation and scale value (that is why you find the texture's X and Y tile values locked together when viewport materials are enabled in the plugin), and these, SW does not reliably display in its more recent versions. I have attempted, at various points in the past, to read the texture parameters you define using the texture-mapping tools, and to then generate mesh UVs based on their values, in order to mimic what you see in the viewport, but this has not been possible to accomplish due to an SW API issue that has just finally been addressed in 2013 SP5 (and there is not a guarantee that it will be possible to use this approach even with the fix), so it may change in the future, but for the time being, Maxwell Studio offers a better solution.
#371978
I posted the same thing a while ago in the Maxwell Render section of the forum but did get no response :( Anyway I have the same problem and what really would make thing easier is when there would be some tools in Studio for selecting triangles, like edge loops etc. Or what would even be better is when triangle groups are exported from SW to Studio on the materials defined in SW, so texturing can be done easily.
#371979
I don't quite understand that last part, because the plugin certainly does write triangle groups. Or are you saying that you want a different export mode, where triangle groups are not written, and instead separate meshes are exported, per material?
#373208
This is frustrating. I have had the same problem when trying to create control panels or graphic labels on products which I am designing only to be prevented by trying to get the graphics to map correctly. Is there a fix in the works for us to be able to do this within the plugin without having to export to Studio?
#382333
The issues with textures in SolidWorks is still a problem in the 3.0.3 plugin. Is this issue being worked on? Was the SolidWorks API issue been fixed in 2014?

I really prefer to work in SolidWorks and find the texture mapping issues to be a major limitation of the Maxwell plugin. I just spent a day trying to get texture mapping to work and ended up adding text and logos as split faces in SolidWorks. It should have been easy to map a texture. I realize that plugins will always be limited compared to Studio, but this feature is important. You guys are smart people... there has to be a work around!

Hi Guys... Just updated Rhino to Maxwell plugin V[…]

SketchUp 2021 Update

Hi there! Sorry, it is the obligatory post relat[…]

Keep in mind that AVAST actually block anything re[…]

Maxwell and Blender

Thanks for looking into this - hopefully you get w[…]