By mtripoli
#350036
Is it just me? I used to assign all MXM materials at the part level and it worked fine. Then that seemed to stop working and I could only assign them at the assembly level.

If I wanted to change a material (at part level) I'd just drag the new one over the old one. That doesn't seem to work either. It's gotten to the point that I remove all materials totally from the part and then start assigning again from the beginning. That can be a drag to say the least. Emitters (for me) always seemed to be hit or miss; I'd assign one (part or assembly) and some would work and then others wouldn't. Then others would and the ones that did stopped working. I'm working on on emulating an OLED display right now and would select all the bodies from the feature tree and highlight them and assign the emitter. None work. Then I decided to try selecting them as a group under "Solid Bodies" and assigning them there and that worked. So someone please, straighten me out on when how and where materials should be assigned. And something I just noticed that seems to have come up in just the last couple of SW driver updates; you can't assign a value below 1 or above (looks like twice) the amount (?) that you originally made the emitter at. In other words, I used to be able to set an led emitter value to 0.1 or .1 and it was allowed; now nothing less than 1. IF the max was 500W the slider would go to 1000. However, you could type in 10000 and it would take it and make it brighter. Now you can't do that. What happened here? With emulating leds it was very convenient to put in sub 1 to tune in the led brightness. Now I can't.
By JDHill
#350040
The main thing to be aware of would be that in Maxwell, it is illegal to have a mesh that has either of the following:
  • triangle groups with emitter materials
  • an emitter material, and triangle groups
This means that in SolidWorks, you can assign emitters at the body or a component levels, but not to a faces or features, and for bodies with emitter materials, you cannot assign other materials at the face or feature level. The plugin checks for these conditions during export and fixes such objects up, reporting error @ 'Boss-Extrude1' (emitter materials illegal for face-assignment) or error @ 'Boss-Extrude1' (multi-materials illegal for emitter bodies) in the plugin log, when it does so. So if you have a problem, check that this is not the cause; if it is not, I would need a specific set of steps by which I might reproduce the issue, because it appears to be working fine here.

Regarding Multilight, there are two things. First, if you right-click in a slider's number edit box, you should find a Decimal Precision item. Second, there is a new feature in Maxwell 2.6 (I am assuming you are using the current version of Maxwell and the plugin here) which allows you to set the scale of each emitter individually. Just right-click on the slider, and you should find a Change Slider Range menu item. So if you like, you can set up a slider to go from 0.0 to 1.0, with whatever decimal precision you wish.
Materials Library not working

Do you mean via web? Or on a particular software?

I'm writing a converter for curves from Houdini to[…]

Free HDRIs for everyone

Thank you!

Hi Guys... Just updated Rhino to Maxwell plugin V[…]