Everything related to Maxwell Render and general stuff that doesn't fit in other categories.
By kingpin
#22133
Well, "/" at the end... environment.plist provided with maxwell defines MAXWELL_ROOT as "/Applications/maxwell.app/Contents/MacOS". However, there have been cases that people needed to change it as "/Applications/maxwell.app/Contents/MacOS/" ("/" after MacOS) to work.

I hope this will work for you, but if not... Can you tell me more detailed info... like what do you mean by "Nothings work"? Does this mean Cinema won't boot?

Kingpin
By Mr. Gog
#22158
Ok...Here we go:

Cinema 4d v9.102: works
Cinema Plug-ins:
Advanced Render
Clothilde
Dynamics
Mocca
Thinking Particles
Material Exchanger
Place on points
Roof Gen
TuileGen
Cinemaxwell

Cinema boot Well.

When i launch a mxs file it launches with maxwell aplication.
It's the only way i can launch the maxwell aplication.

The maxwell aplication doesn't launch without a mxs file.

----
On C4d, maxwell plug in performs right. I can use the tags and everything else. When I press the render button: Maxwell can't initialize, check instalation rules, Maxwell can't initialize, please create at least one camera, then c4d crash. I think it's something wrong with camera!!!

This is the log:
May 5 19:17:01 Fundaci-n crashdump[429]: CINEMA 4D crashed
May 5 19:17:01 Fundaci-n crashdump[429]: crash report written to: /Users/Caedro/Library/Logs/CrashReporter/CINEMA 4D.crash.log


MAC OS 10.4 (tiger)
DUAL 1.8 G5 / 1.5GB RAM / ATi 128MB / 80 GB Internal / La Cie 160GB (ext)...

Tell if you need More...
By kingpin
#22166
Can you launch console.app in Applications/Utilities just before hitting the render button from plugin window? This should give us more info why cinema can't initialize maxwell(there should be more info on console... there should be output from plugin before cinema crashes).

Right now, I can think only two possibilities for the problem initializing maxwell:
1. License.txt is wrong/or in wrong location.
2. MAXWELL_ROOT is not pointing at the directory where mxcl is.

However, these should not crash Cinema, so this indicates other possible problems:
1. Possible conflict with other plugins (Can you try cinemaxwell without any plugin?)
2. Wrong version of maxwell.app

Kingpin
By Mr. Gog
#22190
Test it without any plug in or module. Same happens.

Console Results (two times):
===== Thursday, May 5, 2005 9:57:51 PM America/Santo_Domingo =====
May 5 21:58:59 Fundaci-n crashdump[670]: CINEMA 4D crashed
May 5 21:58:59 Fundaci-n crashdump[670]: crash report written to: /Users/Caedro/Library/Logs/CrashReporter/CINEMA 4D.crash.log
May 5 22:00:37 Fundaci-n crashdump[676]: CINEMA 4D crashed
May 5 22:00:38 Fundaci-n crashdump[676]: crash report written to: /Users/Caedro/Library/Logs/CrashReporter/CINEMA 4D.crash.log

The license is working right on other machine (g5 dual 2.0); the only diference is that it has panther. I tested right know. The maxwell version is for g5. V1 1 33 000 1 alpha.

':?:'
By Mr. Gog
#22191
Kingpin...

How i confirm this:

"2. MAXWELL_ROOT is not pointing at the directory where mxcl is."

Thanks
By kingpin
#22252
Mr. Gog, sorry, I had to go out...

To test MAXWELL_ROOT, try this.
1. Launch terminal.
2. Drag and drop mxcl(no maxwell.app) on to terminal. Terminal should say, something like "kingpin:~ kingpin$ /Applications/maxwell.app/Contents/MacOS/mxcl". (hittng "return" here should start mxcl on terminal... type control-Z to quit.)
3. Then, try "env" command by typing env and hit "return". This shuld list all environment variables in terminal... Find a line start with MAXWELL_ROOT=... This line should say "MAXWELL_ROOT=/Applications/maxwell.app/Contents/MacOS" or "/Applications/maxwell.app/Contents/MacOS/"(compare this one with one you got from step 2. Only difference should be "/mxcl" at the end).

However, since double clinking mxs does render the file, probably, this is not a cse, but please test this anyway (We need to kill all other possibilities).

For camera related error (or To render anything... even empty scene), you will need put a camera in scene, asign "Maxwell Camerra" tag, and then select render camera from maxwell plugin window. It seems like without selecting Render Camera, maxwell or cinemaxwell won't report any error to console.

kingpin
By Mr. Gog
#22336
Everything it's correct.

I always use the camera tag.

Well, don't bother you anymore...

Un millon de Gracias: Kingpin

...anyway i will install panther on another partition...

A million Thanks.
By kingpin
#22358
Mr. Gog.

I am sorry that I couldn't be any help for you :(
I hope that cinemaxwell will work for you on Panther.

BTW it's Friday (Actually it's already Saturday here in Japan.), you know... er... new release? :D

Kingpin

Hi Sam- sorry, I am on a PC.... other than install[…]

Hi, I'm having number of problems using MXS Refer[…]

Same here. I'm on iMac Pro - and it's pretty fine […]

Maxwell for Maya on OSX

+1 Waiting for this one also. Wanna try the textur[…]