Everything related to Maxwell Render and general stuff that doesn't fit in other categories.
User avatar
By fritz_johnson
#397999
Aloha All,
(apologies if I missed it, but couldn't find this exact topic in the forums)
Just installed on a new desktop, and am having a denoise problem. Render runs & completes with & without denoise on, but whenever I activate denoise:

First Pass completes
Second Pass completes
Console reports denoise started, then [ERROR: - Error running denoise process: OpenCL exception ]

Console reports merged display, completion of Denoise channels after the error message, and Maxwell Render viewport shows finished render with Render, Shadow denoise and Denoise icons available. But all images are the same, it appears no denoise has been performed. I've read the release notes on this OpenCL error (memory allocation limit problem) but it shouldn't apply to my system. I've run tests at large and small image resolutions, with and without GPU, fast and accurate, at end and at sample levels, and my new system is fairly robust:

SYSTEM INFO
Num processors: ( logical: 32, physical: 32 )
GPU INFO
Graphics Card 0
Name: GeForce GTX 1070 Ti
Microarchitecture: Pascal
Device Memory: 8192 MBytes
CUDA Compute Capability: 61
CUDA Driver Version: 10.1
CUDA Runtime Version: 8.0
Low Priority Enabled

Most recent NVIDIA drivers (2/4/2019) installed, so shouldn't be that. Any advice would be MUCH appreciated,
Mahalo!
-Fritz
User avatar
By choo-chee
#398017
from the documentation... this is probably because there's not enough GPU memory. they give you also a link for some libraries to install to allow this. make sure not to check the GPU checkbox if you render at higher resolution than what you graphics card can handle.
By Andre Conlledo
#398023
I have the exact same problem. A fairly robust system should be able to handle the denoiser -- I'm using a GeForce GTX 980Ti (so not quite as powerful as yours but powerful enough). I've tryed all options with no luck.
User avatar
By CDRDA
#398028
I have just had this error too... Which is strange as I have the Intel OpenCL package installed. I don't use Denoiser too often, but I tried both GPU and CPU, both with the same error. This is not a memory issue. I think it must be something to do with Nvidia's latest drivers. The last time I used Denoiser was on a 6GB Titan Black, which relatively recently stopped working. My temporary replacement card, a 6GB GTX 1060 now can not seem to denoise a simple 1200x800 pixel image, which the titan black had no problem doing. Perhaps I will reinstall Intel OpenCL and things will work again...
Rhinoceros 6 support

@greengreen , @greengreen , It happened to me […]

Long time not-anymore user here. Wasn't multiGPU […]

Good day! We have just released a new version of […]

Hi there, after a texture tag has been assigned to[…]