Everything related to the integration for Cinema 4D.
I've got an issue with displaying the right material in the preview window in c4d when I'm working with linked materials. You've got this little icon in the material editor where you can choose wich material you want to be displayed in the preview window of c4d. It works well when the material is stored inside of c4d, but when I want to use a linked material it shows whatever maxwell want to display even I've made the same settings like in the material editor within c4d. This is driving me crazy as it always is making the workflow not quite handy. Will there be a fixture some how?
linked material.jpeg
material inside C4d.jpeg
You do not have the required permissions to view the files attached to this post.
Is it possible the MXM file is in a location where you have not permission to modify it (could easily happen, for example, when referencing an MXM from the Maxwell installation directory)?

Because, here, if I edit the MXM file in MXED, choosing a different active texture, and then saving the MXM, then the chosen texture used by the plugin for display, as intended.
I think this is not the reason for it. I normally make my materials in the maxwell material editor or modify them in the maxwell material editor. Than I save them and import them to c4d. The only way to fix that is to unlink the material and modify the settings within the internal material editor. This method is making the files bigger so I would like to avoid it. Even I loose a path it is easier to fix it by the linked material than to fix the textures if the path get lost.
Well, I say that because the only way the plugin knows which texture to use, is to ask the material (MXM) which texture was last chosen in MXED, using the black/orange checkered button near the top left (here, directly under the "material_1" text):

That is exactly what I do. But when loading the material to c4d this info gets lost. So I unlink the material and than I have to change the setting again in that orange/black checker box.
You do not have the required permissions to view the files attached to this post.
Problem is, I'm not seeing that here, so don't know what might be happening. Can you confirm that the desired texture remains selected when following this sequence?
  1. open MXM in MXED
  2. select desired texture
  3. save MXM
  4. restart MXED and open the MXM
  5. confirm that the texture selected in step (b) is still selected
Besides that, maybe try opening one of the standard MXM files (from /Applications/Maxwell 4/materials database) and saving it to your home directory, with a customized active texture, and see if the same problem occurs, to see if it can somehow be specifically related to the MXMs you are creating/using.
Hallo JDHill,
now I've tried several possibilities but it is always the same result. I opened a mxm file from the material database and saved the material with the reflectence 0 texture to my home directory. Than I opened it again to see if the reflectance 0 texture is still selected. So far everything is fine. Than I choose this material in c4d and assigned it to a simple cube but the material is shown with the bump texture in the preview window. So I looked it up in the Maxwell MXED window where it was still marked as reflectance 0 texture. I'm sure there must be a bug. I can only see the right texture when I unlink the material and manually choose the texture within the material editor in c4d. See screen shots.
You do not have the required permissions to view the files attached to this post.
Clearly something is not working as intended, but unfortunately I am not seeing how to figure what it might be, as I am still unable to reproduce it here. So I cannot yet guarantee any fix, but I will certainly keep this in mind.
MXM data base.

At the very least I hope that upon relaunch there […]

Maxwell Render V5 Series

from my (somewhat narrow) point of view I can tel[…]

Thanks Fernando If this will work in the next rele[…]

ilgioma - Gallery

Thanks choo-chee I am very pleased that you like i[…]