All posts related to V2
By kami
#370355
Hello

I know this question has been around a few times, but sometimes I still have problems with it:
Is there a solution for this problem?
Image
(sorry for the extremely ugly example ...)

When I disable the bump on the cussion material, the shading looks good.
But sometimes I really need the bump. And mostly it is not possible to use a denser mesh, if this is a bought model and rhino has no options for making the mesh more detailed.

Thanks
Kami
By numerobis
#370357
No... still no solution i think.

And i think this is the reason why there is no "official" answer in this thread... :wink:

I really hope that this old problem gets finally fixed in v3 - but my hopes are not that high, looking at previous statements regarding this topic and the already known new features in v3. :roll:
Last edited by numerobis on Wed Aug 21, 2013 2:13 pm, edited 1 time in total.
By kami
#370366
Okay, that was a good tip. I did a few test series to come closer.
Image

Without bump or a value of 0.1 it looks very smooth, a bump value of 1 is almost acceptable. With 5, I get these mesh artifacts.
But when I look at the surface on the left side of the image, 5 is around the value I would like to have there.

So to get this both, you mean I would have to make the texture larger? (at the moment 0.3x0.3 meters). The one test with a bump of 5 and a texture of 1x1 meters looks better ...
User avatar
By Mihai
#370382
I don't think that would help in this case unfortunately. There just isn't enough geometry and the smooth shading in the engine breaks down. What happens if you change only have physical sky with no sun, and place instead an emitter to mimic sunlight, but make it not so sharp (so an emitter size that's not too big or small)? Maybe that will keep the shading ok.
By kami
#370406
The sofa has 70'000 polygons, which is not extremely high, but on the other side, usually there are a lot of other pieces of furniture in this room and you would at least need 8-16 times as much for it to look good with the mesh. The better sofas you can buy have around 50'000 to 200'000 polygons, which I think must be enough.

Is there no possiblity to fix this? because without bump, the shading looks perfect...

I did the emitter tests, even though I don't think this is a viable work-around, because it takes longer to clean up and you have to make the fake sun pretty large for it to look good and therefore have no sharp shadows anymore. I also did a test with an hdr which has the same problem.

Image
By PA3K
#370412
Brian is right with idea of diffuse map. I will add this map also to roughness chanel to second BSDF. It can improve some effect on the light/shadow border.

Patrik
By AlexP
#370934
Mihai wrote:I don't think that would help in this case unfortunately. There just isn't enough geometry and the smooth shading in the engine breaks down. What happens if you change only have physical sky with no sun, and place instead an emitter to mimic sunlight, but make it not so sharp (so an emitter size that's not too big or small)? Maybe that will keep the shading ok.
Thanx Mihai, I had same problem and I've subdivided (a lot) sofa and pillows and now it's much better

btw, still the same request over and over but, rou[…]

So far my only option was to ungroup (my group wa[…]

Thanks Miguel I know 5.2+ is a big development hi[…]

SketchUp 2021 Update

Hi Alberto, Many thanks for taking the time to ma[…]