All posts related to V2
By dvsone1440
The separate by material did not work. I have many components (all the same light fixture) within one big component. So I exploded the overall component and separated all the individual light fixture components by material... did not work.
I exploded the outer component.. did not work.
I then exploded all the individual components.... that did work.

I also tried exporting the overall component to a separate skp file... and rendering that.. That worked fine???
User avatar
By Half Life
Are you are using the most recent version of Maxwell? If not it could be an instances thing -- the easiest way to check that is to to disable instances via the Maxwell Scene Manager>Output tab>Export section> Use Instances> set to NO.

By dvsone1440
The strange thing is I had this problem once since I started using maxwell.. but not for a while... and now the last couple days it has been happening on every model... like something has changed, but I can not think of what it would be?
By JDHill
I confirm that the issue is present in your uploaded MXS file, but not when I export from the SKP file. The problematic object is <Component#102> [0.0.0], which has faces inheriting material [Color_E10] from Component#105, which is an emitter in your MXS, but is not, in your SKP.

As I wrote above, the plugin scans through and manually separates mixed emitter/non-emitter objects (groups, components) out into separate meshes, and indeed, if I change [Color_E10] to use the emitter character, <Component#102> is split into five sub-meshes during export. I checked this using both the Ruby and C++ exporters.

Since there doesn't seem to be any sense to the discrepancy, I might suggest uninstalling the plugin, manually ensuring that maxwell.rb and the maxwell folder have been deleted from the SketchUp /plugins folder, and then reinstalling again, just to make sure that there isn't possibly an out-of-date file in the installation.

If that does not help, all I can tell you at the moment is: regardless if the plugin is somehow failing to detect them, the use of mixed emitter/non-emitter objects is illegal in Maxwell, and you can always avoid this issue by not creating them. I'll keep looking to see if I can find a failure scenario on the plugin's side.
By dvsone1440
Thanks JD,
I will try reinstalling the plugin tomorrow. I have not been creating mixed objects on purpose.. so if I am, I just have to figure out how I am managing to get them. Could be an errant painting of a component I suppose.
By JDHill
It can be pretty easy to do in SketchUp, due to the material inheritance rules. If you have a group or component with only some of its faces painted, you either will or won't run into the problem, depending only upon whether a parent component or group has an emitter material, so it need not even involve the action of painting at all (the parent might've been painted last year, for all we care). That's why the plugin is pretty proactive about trying to avoid this. I just want to find out how it is failing to do so in this case.
By dvsone1440
Well Murphy and his damn laws seem to always find me at the most helpful times. Might be that.
By dvsone1440
this error is killing me. I keep getting it right before a final rendering. I do not have any components with two emitter materials in it. and when I save out individual pieces and render.. all is fine.

ERROR: - object [0.0.0] is not an emitter but it has triangles with emitter material
ERROR: - Data preprocess failed. Render cannot continue
[14/November/2013 18:06:26] Ending render process..
By dvsone1440
The hardest part is I can not figure out a way to find the problematic emitter object. Any thoughts on how I can easily find the offending emitter? it always says object 0.0.0??
By dvsone1440
So i have discovered that if I hit the render button in su it works... if I export and then open that in render it does not???
By JDHill
I can't really tell you what "object [0.0.0]" might be without looking at the SKP. In the files you sent last time, there was no problem that I could find in the SKP, but there was in the MXS, implying that there may have been outdated files in your plugin installation, but that's about all I could determine.

Hello everybody! I have a problem with the Fast M[…]

Hi numerobis, if I remember correctly, You can ge[…]

A small issue, when reopening an MXI to Resume Ren[…]


Yeah, as I mentioned in the previous comment, it i[…]