All posts related to V2
By dvsone1440
#367441
Anyone know what is causing this? I have had it a few times and usually delete the object that I think has it... but am curious what is causing it and how to track down / resolve the problem

ERROR: - object [0.0.0] is not an emitter but it has triangles with emitter material
ERROR: - Data preprocess failed. Render cannot continue
[29/April/2013 11:19:23] Ending render process..

ERROR: - Render Failed
User avatar
By Half Life
#367442
You cannot have objects that are multiple material with emitters... the solution is to make the part of the geometry that has an emitter material applied to it separate. Sometimes this can be done automatically at export time via the plugin -- but I don't know which software you are using.

Best,
Jason.
By dvsone1440
#367443
In other words sketchup uses components as the closest thing to "object" as I can assume you are talking about. If that "object" has two emitters within that component I will get this error? Is this what you mean by object?
By dvsone1440
#367444
just tried it.. I had a component with two emitter materials in it. Made one of the surfaces a component within a component... and bingo worked fine.
Thanks
By JDHill
#367446
In theory it should not be possible for this to occur using the SketchUp plugin: it scans to detect such objects and splits them up. So, if you are able to revert the file to reproduce it again, I would very much like to get a copy of the SKP.
By dvsone1440
#367447
I had just enough undo's available to get back to that point. I was able to recreate the error. I will send you a dropbox folder.
By JDHill
#367450
Unfortunately, I'm not able to observe the error here, neither using the MXS, nor exporting fresh from the SKP. Do you happen to recall which component it was that you modified?
By dvsone1440
#367451
yes.. it was the pendant with the wood look. I am now getting the error again and trying to figure out why.
By JDHill
#367452
If you mean, for example, the group named "drum light fixture 24 inch dia," visible in the Scene 25 view, I don't find any problem with that one. I should probably clarify, though, when I wrote above that it should not be possible, this would not apply to any referenced MXS files. So if you have an MXS reference that contains such an error, and it is either exported or not exported for a given export (say, hidden one time, but not the next), then you could see the error occur in what would appear to be an intermittent fashion.
By dvsone1440
#367453
Strange that you don't even get it with the mxs.

Nope.. no mxs with emitters.
I found another object I was having trouble with, once I deleted it and recreated the light fixture it worked.
By JDHill
#367454
Just a shot in the dark, but you might check and ensure that Options > MXS Cache Policy is set to Invalidate, on the off chance that materials are being updated in an already-exported set of data, and thereby allowing an emitter to be applied to a selection of triangles on a single mesh, where it was not the case when the model was originally exported. I would regard this as quite unlikely to be the cause, especially in the case that the scene had been rendered in Fire (you'd find objects flying off into odd places), but technically, it is possible.
By JDHill
#367456
Well, thanks for the files anyway, just let me know if you learn anything more. And I'll let you know if I'm able to discover a set of circumstances in which a failure occurs.
By dvsone1440
#367491
Now I am getting that error all the time. I have been rendering a model just fine. I added one object(Component#85 - its the light shelf in the windows) with a single emitter and it no longer works. Same error: ERROR: - object [0.0.0] is not an emitter but it has triangles with emitter material
ERROR: - Data preprocess failed. Render cannot continue
[01/May/2013 10:36:35] Ending render process..

ERROR: - Render Failed

Jeremy I uploaded a new skp file called EmitterError2 to that same folder as yesterday. I will upload the mxs as well.

Hi there, after a texture tag has been assigned to[…]

Rhino6 Plugin / Rhino Crash

Having fun on my own thread here :) It appears tha[…]

The script will be useful and i think it is easy t[…]