All posts related to V2
#365665
Hello Maxwell team,

like the title says, i would appreciate an answer if new vers. of Maxwell (like 3.0 or whatever it is called in the future) will still support OSX 10.6.8. It's really important for me to know, because i have lot's of stuff compiled and running under 10.6.8 and it would be a lot of time involved to re-compile etc. for Mountain Lion, should i need to update my OS.

I also ask because i'm currently a Maxwell Learning Edition user (1 year license) and in case Snow Leopard would be no longer supported i'm then temped to buy me (before a new vers. comes out) a current perpetual license and then update on a later date to a new vers.of Maxwell.

Best regards
Stefan
#365681
That decision has still not been made, it depends on many variables, including compatibility issues that can arise with 3rd party libraries and support for newer development tools or frameworks. As you probably know new Xcode versions have dropped 10.6 support, and targeting a OS version where we cannot reliably test and debug possible bugs is a no go. Also some 10.7+ only features may improve Maxwell performance (like new libc++ standard library and so), the newer OS version you target the faster the program will work in newer hardware,

The possibilities of not supporting 10.6.x are high. Any Mac that supports 10.6.x (our actual minimum OSX version supported) should support also 10.7 and the upgrade fee is very low. But as said, there is still not a clear answer.

If you have some other feedback that cannot say publicly about your developments please send me a private message.

Best regards,

nachob

A followup question Miguel, I think the following […]

Materials Library not working

Yeah. We have changed to a new website on a new se[…]

SketchUp 2021 Update

Hi CDRA, SketchUp 2021 have changed the sdk and mo[…]

Let's talk about Maxwell 5.2

Good news, thank you Jochen