All posts related to V2
#365456
Something mysterious happened to my maxwell installation...
Starting a render from maxwell studio doesn't work anymore.
Fire in studio is ok, network rendering too. Direct rendering from max and sketchup is ok. I can open a mxs in maxwell.exe and start the render but i can't start it from studio...!?! :?
I have already reinstalled it, but nothing changed.

So what can i do?!?

(Maxwell 2.7.20, Win 7 X64 SP1)
#365478
numerobis wrote:Starting a render from maxwell studio doesn't work anymore.
The problem is that nobody knows what this means. When you click Render, what happens? Nothing? Something? The window opens and then closes, or crashes? Or just opens and does nothing? Or never opens at all? Whatever it is, does the same thing happen, regardless which MXS you try? Is there perhaps a certain texture or other file involved? Have any new applications or drivers been installed recently, or have there been any updates made to the machine or OS? If so, have you tried uninstalling or rolling them back? You say you reinstalled, but did you try deleting any layouts and such from Documents/Maxwell (or preferably, just renaming the folder in order to start fresh)? And did you make absolutely sure the entire Maxwell 2 directory was deleted before reinstalling, in case the problem is caused by some corrupt file there?

Those questions are just the first that come to mind, and nobody can guess the answers to them. All we really know is that maxwell.exe works in general, and that it did, but no longer does, work on your specific machine.
#365481
sorry... i thought this would be clear enough.
Yes, nothing happens, when i click on the render button and with every mxs i tried.

But i can open the same scene in the maxwell.exe and start the render.

I have already tried to reinstall it by overwriting, then deinstalling it first and removing the folders and registry entries. But nothing changed.

I have an image of my install from a few months ago which i will copy back - i hope this will fix the problem.
#365483
Have you checked your MAXWELL2_ROOT environment variable? I guess that if a) Studio ran under a different user than the other applications, and if b) MAXWELL2_ROOT was only defined as a user variable, that this could result in a failure to find maxwell.exe when rendering from Studio. Also, Studio has a console window...maybe you'd find some clues printed there when you try to render.
#365504
ok... i have restored my last windows backup and it is working now.

The Env variables seemed to be ok: "MAXWELL2_MATERIALS_DATABASE=C:\Program Files\Next Limit\Maxwell 2\materials database" and "MAXWELL2_ROOT=C:\Program Files\Next Limit\Maxwell 2"
The studio console showed absolutely nothing.

But thanks for your help, JD ;)
#365516
Ok, i have found the solution...

For material testing i had only the FiRE window open and no other viewport. I thought that an active camera would be enough to start the render.
Now i know that it isn't enough... :mrgreen:
#365519
I really can't say, but I doubt it's that way on purpose. Likely it is just an old assumption in the code, which was made invalid by the introduction of Fire. Since you can have multiple viewports, there must be in the code such a thing as the "current" viewport -- that is what would get rendered when you hit the single Render button. So, no viewport, no render, which would make pretty good sense, if there were no Fire -- who's going to try to use Studio (without Fire) with no viewport? Situations like this can easily materialize as an application evolves -- to catch them, it must first occur to you that they might exist.
#365521
I guess so. :mrgreen: You're pretty good, but not a heavyweight...when I first started coding UI, if I really want to test it, what I would do is have my dad give it a try. He is able to find every possible way of breaking any piece of software in under two seconds. He's like the Babe Ruth of that...some kind of software-breaking ninja -- an ADHD-fueled hurricane of never-before-seen mouse moves. A poor piece of code never sees him coming.

A followup question Miguel, I think the following […]

Materials Library not working

Yeah. We have changed to a new website on a new se[…]

SketchUp 2021 Update

Hi CDRA, SketchUp 2021 have changed the sdk and mo[…]

Let's talk about Maxwell 5.2

Good news, thank you Jochen