All posts related to V2
By jrm1
#364141
I'm working in a model in Sketchup and am experiencing problems with colour. Example: I make an object and give it a colour of white and place it in same area of model as an white item that renders white (same simple skm material) but it renders a warm grey. I've checked that the faces are facing out to viewer but still it renders wrong. Anyone know why?
By JDHill
#364150
Thanks, but the image does not explain much -- please upload the (SketchUp) scene to dropbox or similar, or email it to me at jeremy at nextlimit dotcom.
By jrm1
#364217
Magnus, the floor might be casting warm light, maybe also the sun (but that's 6500k), but you would expect to see a gradation in the light, not a hard junction if that were operating. The ceiling is a very different shade from the walls and they are both set to white.

I've rebuilt the ceiling and assigned a simple Sketchup colour (white) to see if it was the culprit. But no joy.

Many thanks for your input. I'll email the SU file to support.
By numerobis
#364218
Did you open the mxs in studio to see what material is applied to the ceiling? It's obviously a different one than the wall material - maybe the default material.
Is it possible that there is a material assigned to the group?
I think i had this problem too some time ago, but i don't remember how i fixed it. Have you rebuild the group too or only the geometry in it?
Last edited by numerobis on Tue Jan 15, 2013 2:06 pm, edited 1 time in total.
By jrm1
#364220
Thanks numerobis, things there to consider. I'll investigate. Is there a default material that Maxwell applies to a surface? Didn't know that.

I deleted the ceiling and redrew it. It's in its own group.
By jrm1
#364330
In case this is helpful to anyone else, this is jeremy's reply:

Hi Jim,

While the walls in your model do indeed have the [Color_000] material assigned, the ceiling does not, and you can check this for the group and its faces either using SketchUp's Entity Info dialog, or the plugin's Material Picker tool. And just to clarify terminology a bit, saying "color" or "texture" is very different than saying "material", in both Maxwell and SketchUp, and the distinction is not insignificant. It is a material that you apply to geometry, with color & texture being sub-properties of materials.

It is the plugin's job, at export time, to translate your SketchUp materials into Maxwell materials, and the way this is done is determined by how you have set up the material in the plugin's Scene Manager > Materials tab. There, you can specify either the "Embedded" mode, which is the default mode for a material, and which basically allows us to extend SketchUp's very simplistic conception of a material with additional properties like roughness, bump map, etc, or you can use the "MXM" mode, which simply associates the SketchUp material with an MXM file on your disk. The mode for a given material is set using the "MXM" toggle button found at the top-right of the Scene Manager > Materials page.

Auto-MXM is a different thing altogether; how that works is by matching SketchUp material names with the file names of MXM files found on your disk, at export time -- if such a match is found, the MXM file is substituted in place of the Maxwell material which would otherwise have been generated from the SketchUp material. So as you can see, Auto-MXM is a very specific tool, with a very specific purpose: it is meant to allow one to completely ignore (aside from the need to use very specific material names) Maxwell from inside the plugin, and yet to render in Maxwell using MXM materials. I therefore do not recommend enabling this option unless its function is well understood, and its ramifications well considered, because if not, the results could potentially be surprising. But the main point of mentioning this is that Auto-MXM has nothing to do with the automatic translation of SketchUp materials into Maxwell ones -- that is a function which always takes place whenever necessary, according, as I describe above, to how the material is set up in Scene Manager > Materials.

So to answer your final question more succinctly: to make a 240 material, just change the material's color to 240, either in SketchUp's material editor, or the plugin's. To apply further minor customizations, use Embedded mode and adjust the Character of the material using Scene Manager > Materials; to use a fully custom MXM material, also use Scene Manager > Materials, but switch the material into MXM mode, and link to an MXM file.

I hope this helps to explain things.
Support

Hey Fernando case number #00046530 appreciate y[…]

Hello there! I use Maxwell for full scene develop[…]

Studio5.02 and Render are not yet stable on MacOSX[…]

[SOLVED] DOF-button doesn't adjust fstop

Hi, although it's been published in the 5.0.2 rele[…]