All posts related to V2
#317544
Hi all,

I don't know if anyone else has been noticing this problem, but I have just upgraded to 2.0.1.0 maxwell (both on my win7 and xp machines), and the AGS glass has dissapeared of the renders!!!! If I go in material editor, select an AGS material, hit render, it also dissappears.... I did the same test render this morning, before upgrading, and I have beautiful glass. Same MXS, 10 minutes later after the upgrade, no glass.

(That will teach me to upgrade maxwell right before a deadline...)

Could nextlimit tell me/us when they can have a patch out for this???? In the mean time how can I modify my AGS glass to get it to work????

HELP!

T.
Last edited by piroshki on Tue Jan 12, 2010 6:13 pm, edited 1 time in total.
By piroshki
#317545
Here is an image showing the difference:

Image


((EDIT: THIS AGS GLASS WAS FROM THE 1.7 MATERIAL DATABASE, NOT FROM THE AGS MATERIAL WIZARD FOUND IN THE 2.0 MATERIAL EDITOR. USING THE NEW AGS MATERIAL HAS FIXED THIS PROBLEM))
Last edited by piroshki on Tue Jan 12, 2010 6:12 pm, edited 1 time in total.
By JDHill
#317547
Well, there are lots of ways to make materials, so some non-traditional ones (like AGS, sometimes) may fall through the cracks when the 1.x > 2.x translation is done. Point being, nobody can tell what you have to fix, unless you let us know what is in the material. If you want to remove all the geometry from your scene and send it to me (I assume you're using Rhino), I can take a look and see what's going on. Or, you could use the new AGS wizard to re-create the material (look at the top of the material editor, next to the Options menu), if that's more convenient.

(Also, there is currently an issue with maxwell.exe that causes rendering to be done with scattering on, regardless if it is enabled in the MXS file. You can either cycle on/off the scattering checkbox in maxwell.exe, or set scattering to 0.0 in the plugin prior to rendering. Your default scattering in the plugin is probably 50.0, and you can change that if you want using Scene Manager > Output > Presets > Defaults > Store Current after adjusting it to 0.0)
By piroshki
#317549
Cool about the scattering. I was wondering why my images looks... well... weird.

The material in question is the AGS glass found in the 1.7 material database (under your name). The transition from 1.7 to 2.0 worked fine, its from 2.0 to 2.0.1.0 that broke it. I'll try the new AGS wizard and see if that works. I got so used to using the old AGS files I didn't think I needed to create a new one. Thanks for that tip.
By JDHill
#317551
It's not so much a question of where you found it, but when -- in the scene rendered above, did you just freshly import, say, ags_black_75.mxm, or is this a .3dm which was last-saved with the 1.x plugin, which already contained the material, and which the 2.x plugin would therefore have translated? It makes a difference, because in the second case, I do the translation, while in the first, the SDK does it, when it reads the MXM file on the plugin's behalf.

On support they tell me that the case was created […]

Part of this is my fault, I know. I accidentally […]

Hey J, Yes, the assistants have not been added ye[…]

Texture/finish lost in render.

Nothing?