By Josephus Holt
#306791
JD, does the enhanced render instancing in v11.5 have any impact on those of us who use Maxwell (exclusively)?
By JDHill
#306794
I'm not sure, I'll have to check out how it works. I would, of course, expect Maxwell users to leverage the plugin's Instance Object, as that should give you the best performance/control possible.
By JDHill
#306820
Looks like 11.5 won't even load the plugin - it reports 'plugin too old'. Sooo...now I see they posted something in the developer's forum today:
Until the CINEMA R11.5 SDK is avaible here an overview about some major changes:

The R11.5 SDK is no longer backwards compatible in the following areas:

- Shader
- Materials
- Videoposts / Renderer

...
So, the current plugin is good for R9.6 through R11, but we're a no-go on R11.5 for the time being.
By MS
#306855
JDHill wrote:So, the current plugin is good for R9.6 through R11, but we're a no-go on R11.5 for the time being.
Just to make sure - it means I should not go for update to R11.5?

Current plugin wouldn't work at all or only in some areas with R11.5?
By JDHill
#306857
As with many (or most - some trivial plugins will still work) existing Cinema plugins, the current Maxwell plugin will not even load into 11.5. A half-point version update seems like an odd time to break plugins, but that's what they did.
By MS
#306858
This is pretty bad news... :( With a MSA purchased, I have to block automatic updates of Cinema...
By Josephus Holt
#306865
JDHill wrote:As with many (or most - some trivial plugins will still work) existing Cinema plugins, the current Maxwell plugin will not even load into 11.5. A half-point version update seems like an odd time to break plugins, but that's what they did.
hmmm, glad I asked and that you checked. Actually still don't see/feel a compelling need to upgrade from v10.5.
By MS
#306922
JDHill, do you plan to update plugin for Cinema R11.5 and MR v1.7 or only for v2.x? I was told that "all" plugin developers already have access to new SDK of R11.5. Are you one of "all"?
By JDHill
#306950
do you plan to update plugin for Cinema R11.5 and MR v1.7 or only for v2.x?
I don't know the answer to that question at this time; there is another update for the 1.7 plugin, which is pretty much finished, but coding/testing efforts right now are focused on 2.x, to make sure that we have a smooth transition there. Obviously, R11.5 will be supported for 2.x first, in order to respect the investment of people who decide to move up to 2.x, and after that, it just depends on how badly R11.5 has broken the 1.7 plugin. At any rate, we are at too sensitive of a time in development now to consider shifting focus; the changes made in the Cinema SDK are too fundamental to make an accurate prediction about how the transition will go.
User avatar
By macray
#306988
Now I'm interested:
JD, are you developing v2 for 9.6-11 or for 11.5+ at the moment?
Or do you plan to support both versions with differently programmed plugins?
(I mean you have v2 for the actual cinema almost ready as far as I understand you. It would be fine to have the support for the older versions. Not everyone is going to change the c4d license asap.)
By JDHill
#306989
Don't worry, the initial v2 plugin will support Cinema R9.6 through R11.
By RK_art
#307591
Hi, also have this problem with the just this hour installed C4D R11.5.
Too bad and an anger for all 3rd-party-renderer-users that Maxon makes such changes within a mid-step-upgrade.

Hope we don't have to wait too long for Maxwell V2 and that it supports C4D 11.5 and up smoothly ?
By JDHill
#307604
It won't be supported in the initial release since, as I mentioned above, I can't make such deep changes at such a late date and expect that they could be tested sufficiently for a major public release. I understand the urgency of getting it working with 11.5 though, so once I have something that does, I'll see about making an early preview plugin 11.5 available for people on the forum before it's completely done being tested - sort of a 'use at your own risk' beta thing.
User avatar
By Tyrone Marshall
#308359
In the meantime, 11.5 installs alongside version 11. Both versions are available on your system at the same time. Work in 11.5 and then open the scene in version 11 to render through Maxwell Render Version 2.

For the time being, use 32bit C4D Version 11 if MacOSX 10.6 as there are issues with 64 bit C4D, and Maxwell Render V2 on Mac OSX Snow Leopard.

Still I'm surprised that the HDRI images from h[…]

Let's talk about Maxwell 5.2

Matteo, we appreciate your feedback, but we have a[…]

Probably the use of two "." in the file […]

Maxwell and Blender

An addon for Blender would be amazing. It would in[…]