User avatar
By Rochr
#289646
How the heck can you guys get it to work at all?

I did the usual and replaced the plugin, and now i´m getting this (image) message on every single scene previously made.
Can´t even delete the maxwell tags as the message pops up as soon as i move the cursor.


I also tried deleting the 1.7 plugin completely first and install the 1.8 one from scratch, but then the plug wont even show up in Cinema at all.

I´m running PC and XP64.

Image
By JDHill
#289651
An error like that means that either:

a. there are duplicate files on the system
b. the download was corrupted
c. some files were corrupted during unzip

Cinema is trying to read the file that defines the Scene (Settings in older versions) object UI, and it's choking on the file. If you use many polygon objects, you might want to wait until I can get a fix for the triangulation issue released though.
User avatar
By Rochr
#289652
Just tried downloading again through a download manager just to make sure i have the complete file, and got the same result.
I´ve previously tried deleting the whole plug in the Cinema/Plugins-folder, but with no luck. It´s the only folder i´ve extracted the files to.

The scene is just a simple test scene containing four helix objects and a plane. 54000 polys, so no highpoly stuff.

Guess it kinda leaves out the suggestions above. :)

Here´s the scene if it helps. http://www.rochr.com/Testhelix.rar
Works fine in 1.7.1 apart from the faulty camera view export.
User avatar
By Rochr
#289654
I did mess with the variables at one point during the earlier releases, but it has always worked since.

It´s currently set to "C:\Program Files\Next Limit\Maxwell"
By JDHill
#289655
Yes it works fine here too. I don't think this is related to env. vars - the error dialog you showed is not from the plugin, it's from Cinema. It's possible that file confusion could be related to the Program Files vs. Program Files (x86) setup on XP x64. I am not sure about XP x64, but on Vista, the Program Files directory is virtualized when necessary, so depending on what permissions you have, you may not be working with the actual folder when you're unzipping/deleting/copying things.
User avatar
By Rochr
#289656
Well in that case i´m not sure how to solve it.
It would definitely be something i´ve never encountered before.

The file unpacks in the X86 Maxon/Cinema plugins folder. It just don´t show up in Cinema, unless i extract it over the 1.7.1f plug, in which case i get the error message... :cry:


Ok, the next question than, does anybody happen to have Maxwell 1.7.0 with the 1.7 pluging laying around?
That´s the only rock solid setup i´ve had so far.

EDIT: Never mind the last part, i´ve found an old backup.
By JDHill
#289657
'...extract it over the 1.7.1f plug...'

This error is more understandable if that's what you're doing. Try this instead:

- move the downloaded .zip on the desktop
- unzip it in place; you should have a folder named Maxwell
- move the 1.7.1f Maxwell folder out of the Cinema plugins directory
- replace it with the newly-unzipped Maxwell folder on the desktop

I would also recommend not using any 3rd-party unzip tool; the normal XP unzipper will work best.
User avatar
By Rochr
#289658
Actually the "extracting over" was only one of the ways i tried getting it to work.

With the method you´re suggesting Maxwell simply wont show up in the plugins menu. The second i replace it with the older plugin, it does.
By JDHill
#289659
I'm fairly certain that what's happening when you unzip over the old plugin is that you are ending up with both old and new plugins in the folder - the new one is named Maxwell for Cinema 4D.cdl64, while the old one is just Maxwell.cdl64. Which one Cinema will try to load in this situation is anybody's guess, but it is apparently the old one, and Cinema is subsequently unable to resolve it with the UI file that was overwritten by the unzipper, and so you see that error dialog.

So the next thing to find out is: is there anything printed in the Cinema Console when it fails to load? If the plugin is unable to load, it will try to print the reason why to the console.
User avatar
By Rochr
#289661
Well, i started over from scratch here and uninstalled Maxwell and removed all plugins.

I have two folders (doc, res) and 3 files (Maxwell for Cinema 4D.cdl, Maxwell for Cinema 4D.cdl64 and Maxwell for Cinema 4D.dylib) in the plugins folder.

Still doesn´t show up in Cinemas plugins menu though so no way to use the console.
By JDHill
#289662
By console, I mean the Cinema Console, i.e. Cinema main menu > Window > Console. The plugin (other plugins, too) prints messages here to record status and error messages, and such. Just to make sure, since you said you have put these items directly in the plugins folder, here's what that directory should look like:

Image
User avatar
By Rochr
#289668
That´s the console.

And that´s what my plugin folder look like, except some of the file sizes.
My .cdl file is 2 390 KB and the .cdl64 is 4 273.

That may just be the file formatting or there´s something wrong with the zip file (6247 KB).
By JDHill
#289669
Don't mind the file sizes, the ones you quote are correct (mine are newer). If there are no messages printed in the console, and no error messages from Cinema relating to the plugin then I'm stumped, at least temporarily. I'll go step by step over the code and see if I can come up with any new ideas. Could you please let me know which version of Cinema you're running? Here I'm on R11.021 (Build RC 14906), according to the slash screen.

Hi! I have looked for the answer to this but so fa[…]

Settings do not stick

Quick update - if you save the viewport again (in […]

I don't understand why it is so difficult to have[…]

Backplate rendering - reflections

Ok, thanks, so Arnold can do https://answers.arnol[…]