User avatar
By PatSieb
#284824
Hi,

This is my first scene using the new plugin for c4d and it's a pleasure working with it compare to the old one!

a great job you done JDHill, keep the good work! thanks


Image
Image
Image


Just for information : the texture preview has a little bug by reopening a scene created with the plugin 1.8.
Here is an example before and after reopen the scene:
Image
Image

How about the native materials in c4d, will the alpha channel for example working again? I use a lot of 3d trees using this channel in c4d.

Regards

Patrice
Last edited by PatSieb on Wed Nov 12, 2008 6:33 pm, edited 2 times in total.
User avatar
By PatSieb
#284842
thanks luca, i knew this :wink:
By JDHill
#284844
Hi Patrice, yes I have more recently figured out how to prevent the texture-corruption from happening, so you will not see it anymore in the next version of the plugin. Regarding the alpha channel, do your tree clipmaps generally use black & white images, or ones with alpha?
User avatar
By PatSieb
#284847
Hi JDHill,

Thanks for the texture-corruption thing.
I'm using black & white TGA images for the trees.

here is an example how the textures are applied in c4d11:
Image


Will tiff+alpha channel working in the future? (Xfrog use tiff+alpha images for 3d trees)

Regards

Patrice
By JDHill
#284850
Thanks, it seems to me that the (c4d) alpha channel is not being translated right in 1.8; it is putting maps into the Maxwell weight channels, but it is also putting one into the transmittance channel when it shouldn't, so I've changed the code. In the meantime, let me know if it works okay when you export, open in Studio, and disable the transmittance maps for the clipped materials. As far as supporting clipping via rgba files, I cannot say for sure yet, but it might be possible - I will look into it.

Cheers...and thanks for posting some of your images. :)
By dynaraton
#284858
Great job on the new plug-in JDHill. I have started to use Maxwell again!
Can't wait for the new version. Please give us a much needed Sun-Ball (or similar) in C4D and better instancing tool.
User avatar
By PatSieb
#284860
Thanks JDHill for your hard/fast working on this new c4d plugin.
Anyway, i never export scenes from c4d to Studio, sorry for that. :oops:

I know it was already mention but the invert, saturation, contrast settings don't show up in the material editor, i think this is important for the users!

Cheers
User avatar
By PatSieb
#284939
Ok JDHill, i have try to export the tree scene to studio, but no textures are showing up, even the textures without alpha channel. So, what i'm doing wrong, or is it yet a bug?

example:
Image
Image

Thanks

Patrice
User avatar
By spekoun
#284947
Hi. I mentioned alpha before. I would like to see clipmaped material in C4D viewport. I use B&W pictures for alpha too, because maxwell cannot use alpha from tiff, as I know. It would be nice if C4d would use textures from Maxwell material for bump too (enhanced OpenGL can display bump)
By JDHill
#284949
Well, after the conversation above, I've written some new code, where I check if a Cinema material's alpha channel has 'Image Alpha' checked, and whether or not there's actually alpha in the image -- if both of them are true, I can use the alpha to create a copy of the file in b&w and give that to Maxwell as a weightmap, so clipping via Cinema alpha can work automatically using alpha-based clip maps. As far as doing the opposite, i.e. changing b&w maps given in an MXM into alpha maps to show in Cinema's viewport, it is not so simple, because I have no way to determine whether or not that is really your intent - maybe you mean to use it as a clip map, and maybe not.

As far as bump/etc., it is not really the intention that Maxwell Materials in the plugin would be used for setting up pretty Cinema scenes - the function of showing any given texture in the viewport is meant to be used as a utility, the main purpose of which is to provide you with an accurate idea of how textures will be placed in the Maxwell render.

About the screenshot Patrice, I see the 'default' material is selected - could you show me a shot of one of the materials that's supposed to be clip-mapped? It should have two layers, each one using the alpha map for its weight, with one inverted. The second layer should then have the map in its transmittance channel - that is being put there erroneously, so it should be removed. The Cinema material's color channel texture should be getting put into the first layer's Reflectance 0 channel.
User avatar
By PatSieb
#284951
Hi spekoun, i know about the alpha problem, thanks.
But this tree scene is working well in cinemaxwell 1.7 with the c4d materials only.(diffuse and alpha black+white).
Concerning the Studio and the material editor, no textures are showing up in my example, strange?...by the way, i never use Studio.

Cheers
User avatar
By PatSieb
#284957
Ok, i have disabled the transmittance map as you mentioned above and it's working. Thanks

Image
By JDHill
#284960
Thanks for confirming that Patrice - it will work better in the next version, and you will be able to use alpha-based clip maps.
User avatar
By PatSieb
#284963
you are the man 8)
Maxwell Render training

Also, feel free to ask here - if there is no tutor[…]

Can anyone tell me where I can download older plugins?

I need Sketchup Version 4.2.4 - 14 Jan 2020

Why the sphere don't reflect the ground? are you h[…]

ilgioma - Gallery

Thanks tim :D :D Leo