User avatar
By Carl007
I have a problem to get the whole picture...
I have the latest versions of both maxwell and the plugin for C4D.
The upper image is the render straight out of C4D

The following images are rendered in MXCL and shows the different settings for the maxwell scale.
There is some strange cropping of the (0.001) view, that I do not understand.

I work in mm in C4D R10.1 OSX on both intel and PPC and get this problem, so what I have done before is to set the "Multiply Cinema units" field to 0.001 to get the correct scale, and it have always worked.
Not this time.. so I tried some other scale and look what I got...

Perhaps the included picture explains better... I also include the c4d document and a MXS document in a zip archive. Please someone correct me in my lesser understanding of this issue.

Sorry for the big image size and the jpg artifacts.
The little grey box in the middle is supposed to be 10 mm small. ... /
User avatar
By zoetropeuk
No, it's not related to that thread. I have exactly the same problem. No matter the output settings, view rendered etc all my final images are zoomed in 10-15% :(

User avatar
By mashium123
Yes, must confirm...

I opened your scene in c4d10.1 demo and have to confirm that the results vary when changing the option "Multiply Cinema units by:".

I made a similar test scene with my regular c4d9.6. The same bug(?) here.

I compared four different scale situations by loading the generated mxs files in studio.

Focal length changed:

c4d camera in c4d -> 36
multiply factor 0.001 -> 51.070
multiply factor 0.01 -> 37.095
multiply factor 0.1 -> 36.107
multiply factor 1 -> 36.011

Btw: the "recommended" multiply factor is 0.01, if I remember correctly.

Sooooo... things are quite messed up here... :(
Last edited by mashium123 on Mon Jun 04, 2007 11:29 pm, edited 1 time in total.
By patrikpanda
.hm, strange.i haven´t had such a problem so far...
User avatar
By Carl007
Thanks for your replies.

What a strange situation really...

Hope the c4d pluginmaker is reading this and know the answer, by the way, who is making the plug for c4d?

By lllab
i have that too with the new plug!

it renders a resolution i dont have set(smaller) and it dropps the view now!
so again this plugin has new surprizes sadly...

please Nl team repair this, it makes working with c4d plugin not really ok.
By Becco_UK
I've done several different sized preview renders with the new Maxwell 1.5/Cinema plugin and not had the problem being described here (PC system).

Use the value 0.01 which is also the scale value used by RealFlow.
By lllab
i also use 0.01 and i am on pc.
it happens with the updated plugin.
By lllab
now i have a file where it works correct...
bad thing is i dont know the difference.
will check more...
User avatar
By mashium123
lllab wrote:update:
now i have a file where it works correct...
bad thing is i dont know the difference.
will check more...
What do you exactly mean by "correct"? Did you try and open the scene(mxs)file in studio and check the focal length of the cam? Was it the same as in c4d? (Please see my post above...)
User avatar
By Kabe
mashium123 wrote:Btw: the "recommended" multiply factor is 0.01, if I remember correctly.
As a general rule this is plain wrong.
Or let's say: It depends...

What I actually once recommended was that with Cinema's limitations in
floating point accuracy it is generally a good idea to map 1 Cinema unit to
1 cm - so you would choose to declare "cm" as working unit.

This way the usable range covers objects from little insects to big houses,
which should be good enough for most purposes. Above or below this
range you start to discover numerical inaccuracies, rounding errors,
display problems, because 32-bit floating point math is much less
accurate than your desktop calculator.

If and only if you follow that suggestion, which has nothing to do with
Maxwell but is all about working in scale in Cinema, then and only then
the multiply factor is 0.01.

If you work in "mm" like Carl, then it is 0,001, if you're building a whole city
you might rather use "m" and you would use 1 as a factor.

To sum it up: Choose a unit that works for your scene, then adjust the
multiply parameter accordingly.

Hope it helps


P.S.: The starting issue is a bug and it will be fixed soon.
User avatar
By mashium123
Kabe wrote: P.S.: The starting issue is a bug and it will be fixed soon.
Nice to see, that the topic is addressed and confirmed as a bug, even if it is done ByTheWay...
Now is this one: ... hp?t=23731 related to this bug?

Hey thanks for the help so far. I think the image[…]

4K Support not working

Oops. Sorry, I opened V4 not V5. The latter fits i[…]

Hi again dear customers, In the version we upload[…]

Hi, You can create it in the MXED and then use th[…]