By Yog
#226853
Running XSI-6.01.
Whenever I try a preview or render, the Maxwell Render UI pops up and from the console I can see the first thing that happens is that Maxwell creates a MXS file, the very next message in the console is that it cannot find the MXS file and then aborts the render.
However if I go to where Maxwell said it created the MXS file, I can double click on it and it will render fine.

Anything I can do to render within XSI, rather than hopping out of it, searching for the MXS file and rendering from Windows Explorer ?
User avatar
By Mihnea Balta
#226861
Does the path to that file contain any funny characters like kanji, extended ASCII etc.?

What if you enable "Save MXS" in the renderer options and then set a very simple MXS path like c:\test.mxs? Does it work then?
By Yog
#226894
No odd characters in the path.
Here is a screen grab of the console.
Image
User avatar
By Mihnea Balta
#226905
Could you post a screenshot of the Maxwell render options panel? Is your "MXS path" set exactly to "C:\Softimage\XSI_6.01\Data\test.mxs" or is it missing the extension or something like that?

It's trying to render an animation, which means that it expects to find multiple files called "test0001.mxs", "test0002.mxs" etc. Do you have a single file in the "C:\Softimage\XSI_6.01\Data" directory?

Does this happen on a very simple scene (e.g. an empty scene)? Could you share it so I can debug it?
By Yog
#226926
I've simplified the path right down to just the "C" drive, still the same errors, either at render region or full render.

Scene Panel
Image

Region render panel
Image

Render Panel
Image
User avatar
By Maximus3D
#226931
Um, your MXS path got one too many slashes in it (i think). Try to remove one and see if it helps..

/ Max
User avatar
By Mihnea Balta
#226936
Region rendering is not supported properly yet, it will be added in a future update.

Can you send a scene file where you get the problem to mihnea.balta@gmail.com? Do you get the problem by creating an empty scene and trying to render it with Maxwell (after setting the MXS path)?

The extra slashes shouldn't cause any trouble, but try without them anyway as Maximus3D said, just to make sure.

Could you also post a screenshot of the preferences panel found in the preferences manager under Custom -> Maxwell?
By Yog
#226938
Maximus3D - XSI creates the extra "\" automatically, although it creates the MXS file in "C:\Test_Render.mxs"

Mihnea - Will do. Many thanks.
By Yog
#227007
SORTED - with the help of Mihnea.

In XSI's Render Manager, the default setting for Pass Frames is "Use Scene Render Options", if I set it to "Frame Range", then all renders fine.

Thanks for the help :wink:
User avatar
By Mihnea Balta
#227018
We'll fix this bug in the next update.
Plugin for modo 14?

Unfortunately the Modo development and plugins hav[…]

Hi, I submitted a support request for this, but t[…]

Maxwell Render 5 crach

Maybe computer saw your target SL and just gave up[…]

Indeed it is great to see the Maxwell Team motivat[…]