#269780
Hello... After digging in, I found why I cannot save some of my work made in Maya in Studio. The maya plugin offers an option called "protect geometry" (don't know why, for what reason or whatever), so Studio cannot re-save work done in maya--> exported to Studio --> re-save and render in Studio (happened to me with a model done in sketchup, imported to maya, then for Z-clip I have to export it again to Studio). So I figured out, why not un-check that weird "protect geometry" option - but un-checking it does nothing... still impossible to render with Z-clipping that I adjusted in Studio - I get the same error "cannot write filename.mxs". How the heck can I get rid of that stupid protection ? why is it there at all ? thanx ..!
User avatar
By Mihnea Balta
#269781
That error is not caused by protected geometry. Check if you have per-face material assignment on objects in your scene. There's a bug in the SDK which causes all the 1.6 plug-ins to produce MXS files which cannot be handled correctly by Studio if per-face material assignment is used. The scenes work fine when rendered, but can crash Studio or produce that error message.

The problem has been resolved but the fix will not be available until the 1.7 release. The workaround is to split the objects with multiple materials so that you only have one material per object (or skip Studio for the time being).

The protected geometry flag was requested by some customers who provide models in MXS format for use exclusively with Maxwell. They didn't want the objects to be exported as OBJ from Studio and then used with other 3D packages. That flag does not prevent you from modifying a scene in Studio and then rendering from there, as you can see with a MXS which does not use per-face materials. Anyway, it's going to be off by default in the 1.7 release.

If you don't have per-face materials in your scene, this might be a new bug, so could you provide more details, or send me a scene which reproduces the bug?
User avatar
By choo-chee
#269782
hmmm.... the scene is very big (you can see it in my new post at the gallery), but since I got the base of it from a client it might be what you say. So, is there a way to bypass studio and Z-clip in maya ? in studio it's very easy to Z-clip but there's no dynamic interface in maya for the clipping (I don't even know where to type in the Z-clip parameters....), thanx !
User avatar
By Mihnea Balta
#269787
In the camera attribute editor, under the "Camera Attributes" rollup, you have fields for the near and far clip planes. Uncheck "auto render clip plane", then use those two fields; you'll get a viewport preview too. This is how z clip works in all Maya render engines (software, mental ray etc.).
User avatar
By choo-chee
#269788
you rock my world ... :)
User avatar
By choo-chee
#269789
p.s. - about the Mental ray problem, I simply renamed the mayatomr.mll as mayatomr.m__ so it never loads...
User avatar
By Mihnea Balta
#269792
That issue should also be fixed for 1.7, as I've rewritten some parts of the attribute editor code to work around some Maya bugs. Unfortunately I can't reproduce the bug you reported, so I'm only guessing that my change should fix the problem.
opening V5 files in v6

just installed latest version for Rhino V6 when I[…]

Daydreamer

I love it!!

I hope someone can help me! This is almost certain[…]

Multiple HDRI's

I can almost feel your jubilation~! Yes, agree, it[…]