By rickyinmotion
#262394
With the new plugin for maya on OSX
I've got this message and I've got no preview of the shader

// Error: Cannot render preview for material 'maxwellMaterial1': cannot read back rendered image. //

Thanks in advance for your support
By zapalamon
#262466
I get the same error when creating my own material and updating the material preview image. I just close Maya and restart but it would be nice to know what is causing this problem.

If anyone know of a work around or a solution please let us know.

Thank you.
By rickyinmotion
#262468
great, i'm not alone.
If one of the nextlimit team could answer, it will be cool
User avatar
By Mihnea Balta
#262487
Does normal rendering work? Are you using the latest MXCL too? Did you change the preview scene in the plug-in options? Could you tell me what your preview scene is set to by going to Window -> Rendering Editors -> Maxwell -> Maxwell settings?
By rickyinmotion
#262501
Thanks for your support. Follows the different answer
Last version of the different component of maxwell installed
System OSX 10.5.2
Importing an mxm shader from the library : ok
Rendering from Maya : ok
Creating a fresh maxwell material in maya : not ok (preview impossible)
when I click on "update preview" button
Preview scene : /Applications/Maxwell/preview/defaultpreview.mxs

Hoping that helps
By rickyinmotion
#262619
No news ?
Is it a bug ?
Thanks to answer
User avatar
By Mihnea Balta
#262645
We're not sure what happens yet. The error message means that MXCL runs, but doesn't render a preview image when asked. This can happen because of several reasons. Do you see MXCL starting at all when you hit update preview, or does Maya print the error message immediately? Do you have several Maxwell versions installed?

If we can't track it down by Monday, we'll send you a special plug-in build which prints more details so we can figure out what's going on. In the mean time, sorry for the inconvenience.
By rickyinmotion
#262655
and I forget one version of Maxwell installed on the Mac
By msantana
#262750
I have exactly the same problem and not only that, but every time I run a Maxwell render from within Maya, it renders correctly, but I have to kill the maya process (the one from the render) otherwise it will not import the image into Maya. Not to mention that there should not be an extra maya process running and eating memory anyway...

Running Maya 2008 on:
  • a 8-core Mac Pro (early 2007)
    OS X 10.5.2
    on an Apple RAID
M
User avatar
By Mihnea Balta
#262755
rickyinmotion: in your image, Phase 2 happens after MXCL quits? And after you dismiss the dialog, does Maya go away?

msantana: rendering shouldn't launch a new Maya process unless you're using batch render. If you are doing a batch render, it won't bring back an image at all. Are you getting a second Maya process when using "Render Current Frame"?
By rickyinmotion
#262766
For Mihnea Balta : yes phase 2 happens after MCL quits
and no Maya doesn't go away after I dismiss the dialog
Hope it helps
By msantana
#262795
Well, I run Maya 2008 and then when I do a Render Current Frame a second maya process is launched, then MXCL is launched and renders fine. Then I press stop when I am happy with the result and then the image will not display in the Render View (it is just a gray screen).

Then this additional maya process starts hogging one of my cores (around 100%) and if I kill it, then the image is imported to maya... Weird I know. I didn't report it because this, along with the preview error that ricky reported started happening after I updated from 10.5.1 to 10.5.2.

Perhaps a bug with Leopard? I haven't tried reinstalling the maxwell plug-ins or maya. A new maya update is I believe coming out in March, maybe that will fix it (or break it even more?) ?

I had some very strong highlights in some material[…]

Daydreamer

Thanks everyone! I didn't want to use volumetrics […]

opening V5 files in v6

just installed latest version for Rhino V6 when I[…]

I hope someone can help me! This is almost certain[…]