Everything related to the integration for SketchUp.
User avatar
By CDRDA
#394447
Ever since upgrading to Maxwell 4 with Sketchup Pro 2017 the Export to Studio icon on the Maxwell Toolbar has been greyed out. The same is true for the menu option too. Is this something to do with Studio needing a separate license? Is there a way to enable the export function, or is it this a known issue?

Another problem I have been experiencing is intermittent issues when sending to render from within Sketchup. Often after a cancelling FIRE, or a render before being fully exported, subsequent renders will not work. Looking in the folder where the render is to be saved, an mxs file is created with the correct name, but only 4kb in size. Re-opening the Sketchup file resets everything and the render will work fine. This also happens if I have multiple scenes in Sketchup and render each one out after another. The first one always works.

This started to happen in Sketchup 2016 running the last version of Maxwell 3... Interestingly, I have changed the Cache Policy option to Prompt as opposed to use cache and I think this has solved the problem...
#394454
Yes, the Maxwell for SketchUp product only includes Maxwell Render, not Maxwell Studio, which was made into a separate product. So, I probably cannot answer your question directly (not knowing your license situation -- you may want to consult sales through your portal.nextlimit.com account), other than to say that if the plugin is able to find Maxwell Studio, the button will be enabled. Even if Studio is not licensed, the button will be enabled; the plugin would export the MXS and open Studio, which itself would pop up an error dialog about not being licensed properly.

As for the second issue you describe, it is not possible for me to guess what might be the problem, unless/until I am able to reproduce it here. So thanks for the detail about Cache Policy; that this should help implies that rendering the data must damage it in some way that prevents a valid MXS being successfully written. There is always a risk of this, but the benefit of not re-exporting data is substantial enough to make it an option, instead of just having the plugin always export from scratch (meaning, remove the option and have it behave in all cases as though it had been set to Invalidate).
User avatar
By CDRDA
#394460
Sorry, yes I have a full license for Maxwell Studio as well as Sketchup, so the button should be available. I have since tried reinstalling the Sketchup plugin, but the button is still greyed out.

I have also tried running studio first before Sketchup to see if, on the off chance that makes a difference, but no joy. I'm running Studio version 4.0.1.1 win 64 and Sketchup 4.0.8 version of the plugin. Is there a way to point the plugin to studio? I still have installed Maxwell Version 3 (Studio) and the plugin for Sketchup 2016.

I can still Export MXS from the toolbar, so it is not a great problem, but slightly annoying nonetheless.

With regards the render sometimes not working from Sketchup, I must also say that this is a recent phenomenon, so it may be related to a Windows 10 update, or perhaps a driver update.
User avatar
By CDRDA
#394461
I have further tested the Cache options with interesting results. Setting the Cache to invalidate, or prompt does indeed allow me to render normally. Prompt however initially states that Maxwell Fire is active, even when not and the data it contains can be released and a full export can be performed etc. Clicking no will perform the full export and everything works fine, clicking yes however closes the pop-up box and does nothing.

Seems like the plugin is not detecting if Fire is closed correctly?

Anyway, hope this helps shed light on the issue.

Thanks.
#394466
CDRDA wrote:
Thu Jun 01, 2017 9:43 am
Sorry, yes I have a full license for Maxwell Studio as well as Sketchup, so the button should be available.
The plugin is unaware of whether Studio would be licensed or not, it only knows whether it is able to locate studio.exe.
CDRDA wrote:
Thu Jun 01, 2017 9:43 am
I have also tried running studio first before Sketchup to see if, on the off chance that makes a difference, but no joy. I'm running Studio version 4.0.1.1 win 64 and Sketchup 4.0.8 version of the plugin. Is there a way to point the plugin to studio? I still have installed Maxwell Version 3 (Studio) and the plugin for Sketchup 2016.
The way the plugin finds Studio is by looking at the MAXWELL4_ROOT environment variable, which should be set by the Maxwell Studio installer. Please see the notes regarding MAXWELL4_ROOT, here.
CDRDA wrote:
Thu Jun 01, 2017 11:34 am
I have further tested the Cache options with interesting results. Setting the Cache to invalidate, or prompt does indeed allow me to render normally. Prompt however initially states that Maxwell Fire is active, even when not and the data it contains can be released and a full export can be performed etc. Clicking no will perform the full export and everything works fine, clicking yes however closes the pop-up box and does nothing.
Thanks, I see what you mean; I'll check into it.
Last edited by JDHill on Thu Jun 01, 2017 5:41 pm, edited 1 time in total.
User avatar
By CDRDA
#394467
The way the plugin finds Studio is by looking at the MAXWELL4_ROOT environment variable, which should be set by the Maxwell Studio installer. Please see the notes regarding MAXWELL4_ROOT

Thanks JD, that did the trick nicely, I now have the Export to Studio icon functional!

Here are some more renders. I've reworked the crea[…]

Most difficult seem to be partially transparent cu[…]

Oh wow - those are some serious gourmet sh%t Ha[…]

Let's talk about Maxwell 5.2

Matteo, we appreciate your feedback, but we have a[…]