Everything related to the integration for Rhinoceros.
User avatar
By John Krikawa
#397477
I ran into a problem where I had created a textured material in mxed and then had difficulty scaling the map in Rhino. No matter what I did, the Maxwell rendered material resulted in a grossly zoomed in view of the texture. Changes to the mapping size in Rhino did not change the Maxwell render. The Rhino viewport (Rendered setting), showed the scaling the way I wanted it and I assumed it would be reflected in the real render (or FIRE), but it did not. I used planar mapping to be sure I had control of it and also so I could set the scale/rotation with the mapping tools.

When I examined the material closer in mxed, somehow one of the mappings had gone from "relative" to "meters" in units. I work in small mm unit scales, so I thought that this might be the problem, but when I switched it to relative (and checked all the other mappings) there was no joy. I then recreated the material from the ground up, parameter by parameter, using the material editor in Rhino and the material behaved just fine. I was able to map and change the scale of the texture inside Rhino, with no problems. I wrote it off as a quirk or some kind of user error.

But, today, a similar thing happened. I downloaded the material "Madagascar Ebony" and applied it to an object and adjusted planar mapping on it: I am unable to scale it. It shows scaled in the Rhino rendered viewport, but FIRE or MR makes the texture huge (and pixelated). Is there some other fix besides rebuilding certain imported materials inside the material editor within Rhino? Is this a bug? Here's two different zoom levels. Even in the first one, the map isn't lined up like it should:
Image Image
User avatar
By Mihai
#397478
Do you have maybe more than one UV maps on your object in Rhino? It still has a cubic map, besides the planar map you added? If you could post a screen shot of your Texture Mapping settings in Rhino, and also check which channel the textures in this material are set to use. If they use maybe channel 1 instead of 0...
#397550
Hello John,
It would be interesting to open the output mxs file in Studio to see what's actually happening inside. Could you send it over?

If I'm not wrong, when you change the mapping type from Relative to Meters, the plugin is adding a new set of cubic UVs of 1x1x1m

Best,
Fernando
By Jere Toivonen
#397884
I have been battling with the same issue for two days straight now, but I finally think I found a quick workaround. Editing the material in Rhino, I used Ctrl+Shift when selecting Relative. This should apply the change to all textures at once. I have no idea why this worked, as I had gone through every texture by hand multiple times.

Hope this helps!
User avatar
By Nasok
#397885
Can't say for Rhino :)
but generally this might happen due to multiple UV sets. Usually when ever you create an object an empty uv set is created and when you apply a Planar map - that's another uv set (unless you overwrite).
Exporting it to mxs (ob obj .. fbx) - is a good idea to check what's going on.

On the other side it might be the way you created the object. If the object itself is massive, 2m x 2m and you're masking out (with trimming tools) only a few centimetres - then, well, get ready that when you apply planar mapping -it will be applied to that original object not to trim result - especially if you have you "history" - on.

So the safe way would be to remove the construction history before applying any sort of UV mapping to make sure that UV mapping will not take the original starting object in consideration. Checking UV panel should help you identify that, but again, - try exporting it to mxs, obj or fbx to check what's going on - if you want share it here - I can help with that.
Cheers.
User avatar
By John Krikawa
#397888
I apologize that I haven't been able to follow up on this thread as I'm in another "work mode". I still have the little test model and scene. I will certainly revisit when I am rendering again. All of the suggestions are interesting. I would note that I stopped using the standalone mxed and I don't recall having the issue again. For the most recent project, I only used the material editor inside the Rhino plugin.
-John

Hello! We have just released a new version of the[…]

Let's talk about Maxwell 5.2

I have to say, as I've mentioned before, getting 1[…]

New podcast - CG Talks

Hi guys! We've just finished the first season of […]

Thanks, Luis, appreciated. It looks like industria[…]