#366649
If you use Maxwell’s network rendering you will undoubtedly run into a situation from time to time where you need to reset one, or all of your render nodes. The Network Monitor
has a button that is called “Reset network” but it doesn’t actually restart any of the nodes, it will just shut them down. This leaves the user with the task of manually launching
the node on each one of the computers. As you can imagine this is terribly annoying and time consuming. I have found a solution which lets you run one batch file and start all
of the nodes, which I’ll outline below.
***Please note that this can be somewhat finicky setting up due to different sharing/security settings
on each person’s computer so it may take some research or experimentation on your end to get it exactly right.


Download and Install Psexec:
1. Download and install the program “Psexec” (it only needs to go on your main computer, not your nodes)
Download link: http://technet.microsoft.com/en-us/sysi ... 897553.aspx
Tutorial on how to install and use: http://www.youtube.com/watch?v=MaAL3C-DuHQ


2. After installed open up the command line on your main computer quickly test if you can login to one of your computers by typing the following line:

Psexec \\staticmachine01 -u XXXXXXX -p XXXXXXX cmd
Green = computer name or ip
Blue = computer login
Purple = password



If you are SUPER lucky this will have worked and you are logged into your node computer’s command line. You can tell if it worked by looking at the top bar on the command line’s window, it
will list the computer name and the program. In my case is says: \\staticMachine01: CMD Odds are it didn’t work and you got an access denied. This is because the correct sharing
and or admin privileges are not setup correctly yet. This is where it becomes a bit of a pain since there are many things that could be causing issues. Below I’ll give you some things to try to
remedy this:

Set up a mirrored admin account on your node computer:
On your main computer make sure your user account is set to admin. On your node computer setup a
user account and password with admin privileges that is exactly the same as the one on your main
computer. It must have a password as far as I can tell, otherwise Psexec isn’t happy

On your node computer make sure the firewall is either turned off or is set to let Psexec through

In the Network and Sharing center make sure sharing option are all turned on

On your node computer add a new security registry setting :
1. Open regedit and go to the following location:
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system
2. Create a new D Word named: LocalAccountTokenFilterPolicy
3. Set value to 1
4. Restart computer

These are the main things you need to check to get the sharing to work which will let Psexec. At this point go back to step two and test out that line of code in the command prompt again. At this point, it will hopefully be working. Below I’ll show you how to use Psexec to launch Maxwell nodes.


Using Psexec to launch Maxwell Render nodes
1. Open CMD
2. Type the following command:

psexec -i -s -d \\staticmachine01 -u XXXXX -p XXXXXX "C:\Program Files\Next Limit\Maxwell 2\mxnetwork.exe" –node
Green = computer name or ip
Blue = computer login
Purple = password
Red = path to Maxwell render node on the remote computer


This will launch a Maxwell render node on your node computer, yay! Almost finished. Now we need to make a batch file out of this so you can just click an icon and have this run. Below outlines this:

Creating a batch file to launch all of your render nodes
1. Open Notepad
2. Type the line of code from the previous step. Add a new line for each render node, adjusting the computer name, username and paths according
3. Save file as a .bat

Finally! After all of this, we now have an icon that you just double click on and all of your render nodes will launch. No more manually launching them on each computer. Hopefully this worked for you…as I mentioned the sharing/permissions aspect of this seems a bit finicky since there are so many things that can affect this but the steps I’ve outlined are the main offenders. Good luck!
#378685
is this still working with v3?
When i start a maxwell node using psexec the mxnetwork.exe is listed under processes but not as task.
It is recognized by the network manager, i can start a job and the list entry displays "rendering" - but nothing happens on the node, it is NOT rendering.

:?

(Win 7 x64 SP1 on all machines)

Thanks Luis, it's great to see progress with MW!

Thanks Fernando!

Attic

Hi, https://www.janwalter.org/assets/attic_maxwe[…]

HDRI

Hello Mike, I'm not sure what you are doing with […]