Everything related to the integration for Archicad.
By Andreas Akerlund

After intstalling the plugin for Archicad 20 the following error message is shown during startup of Archicad. As far as I have tested the plugin functions normaly and at least the volumetric gdl part works. Any ideas?
You do not have the required permissions to view the files attached to this post.
By Marton Day8

Please look into the ARCHICAD\Add-Ons\GDL folder

do you see the MaxwellExtensionGDL_AC20.gdx and MaxwellExtensionGDL_AC20.version files there?

By Marton Day8
The add-on should copy the MaxwellExtensionGDL_AC20.gdx file automatically, but in your case it doesn't happen somehow.

Where have you installed the plugin files to? What is the path name?
Inside the plugin install location, do you see the file MaxwellExtensionGDL_AC20.gdx?

Maybe the plugin can not copy this file into the add-on folder. Is there any write restriction on your add-on folder?

By Andreas Akerlund
Hi again Márton!

Thanks for digging into this.

I have installed Maxwell for Archicad in default folder C:\Program Files\Next Limit\Maxwell for ArchiCad.
I have then loaded via the addon manager the Maxwell_AC20.gmx and MaxwellController_AC20.apx. In previous installations this has sufficed for the correct gdl-library to be aplied to the embedded folder.
I see now that the file you refered to (MaxwellExtensionGDL_AC20.gdx) are placed in C:\Program Files\Next Limit\Maxwell for ArchiCad. Should I manually copy them to add-on/gdl?
By Marton Day8
Ok, so you have the file.
The question is why it was not able to copy it to the add-on folder. Please try to copy it manually (can you copy it without problem? Does it asks for special permission?). In case the file is there, it should work OK.

By Andreas Akerlund
You are right, it is a permission issue.

The error message persists when I copy the file but the warning in the gdl-objects disapear.

I changed the permissions on the add-on file and reinstalled Maxwell for Archicad. Now it places the file correctly and an additional file with .version ending. Probably the lack of that file that caused the error message to continue after I copied the file.

Now it works fine!

I have checked other desktops with Archicad 20. All have write restrictions on the add-on file. Since it is nothing we have done intentionally it may be a recurring problem for other users as well?

Thanks for helping out!
By Marton Day8
Unfortunately it is not possible to add the GDL add-on via the Add-On manager, so the current solution is a workaround.

I will think about what else can be done to make it more safe (maybe a clear message like - the Add-On folder is write protected, please unlock the protection - or something like this could help)

By sinatropus

Same problem with the v21. But additionally the MaxwellExtensionGDL_AC21.version doesn't seem to appear in the C:\Program Files\Next Limit\Maxwell for ARCHICAD folder. Only the MaxwellExtensionGDL_AC21.gdx is found. But copying only one of the files still gives the same error in AC. Where can I find the missing MaxwellExtensionGDL_AC21.version?
By Andreas Akerlund

I can rapport that the problem seems gone in Windows 10. We had the issue in Windows 8.1.

I also noticed that the version file was missing but it seemed to only affect the error message not the library itself.
By Marton Day8
Hello sinatropus,

Which version of Windows do you use?

For the new plugin version I will find a better way to check version information, this MaxwellExtensionGDL_AC21.version file is nor reliable as it seems.

It is a super simple file, and after first run the plugin should create one inside the C:\Program Files\Next Limit\Maxwell for ARCHICAD folder. If it is not there after first run, maybe we have a write permission issue there .

For now the easiest solution is to download this file from here
https://www.dropbox.com/s/ossulbih71jmx ... rsion?dl=0

In case you use an earlier version of ARCHICAD just rename at the end of the file name "AC21" to your "ACxx" version. And copy it into the ARCHICAD\Add-Ons\GDL folder.

By sinatropus

Windows 10 version 1607. I also run the setup as administrator, if that's worth anything. All the Archicad folders have partial (square not tick check-mark) Read Only accessibility which doesn't seem to save when changed (still the same after checking the properties again).

This file fixed the error, thanks. Another remark goes for the version 4.1.3 which made archicad crash every single time the maxwell file dialog button (three dots) was pressed. 4.1.4 from dropbox worked, but it took a while to find the forum posts where it was reported. Is it beta that it's not on the download page?
New podcast - CG Talks

Hey guys! We have just finished the second season[…]

hardware question :)

Same here. I built my workstations based on Intel […]

So I've jumped into Maxwell again after a few year[…]

Let's talk about Maxwell 5.2

I stick to Maxwell for now only because the easy t[…]