Everything related to Studio.
User avatar
By Forum Moderator
#397697
I would rule out anything related to the licenses, as they are not constantly checked; only when Studio or Maxwell are started or when launching a render from a plugin.

I am constantly connected to internet and I guess most of the users are too; we would have gotten many reports from the users if that was a general problem caused by Studio itself. There must be something else related to either a particular setting in Studio or in your system that is causing that.

Could I check your studioprefs_v4.ini file? You should be able to find it in this folder: C:\Users\<username>\Documents\Maxwell
Or better, just close Studio, then remove or rename it and open Studio again. A new studioprefs_v4.ini will be created with default options; then check if it shows the same behavior.

Another option could be a security application trying to block Maxwell activity (but this doesn't sound very probable).

Please, let me know how it goes.

Best,
Fernando
User avatar
By CDRDA
#397698
Another option could be a security application trying to block Maxwell activity (but this doesn't sound very probable).
Given the current version of Unreal Studio with datasmith has trouble authenticating when Kaspersky is installed, along with a number of other programs such as Teamspeak and other anti-virus, this could potentially be the issue. The current solution is to uninstall the offending app, authenticate and then reinstall. It does sound a bit far fetched in this case, but even when port forwarding and allowing specific ports in the firewall, the connection problem persists with the datasmith plugin. Perhaps there is a conflict with another program....
By feynman
#397699
Well, we don't have Unreal Studio or datasmith, whatever these are, installed; only legitimate industrial design CAD software and Microsoft's Office package.
User avatar
By CDRDA
#397701
Unreal Studio is the new name for the Arch viz/Industrial/product viz version of Unreal Engine 4, with Datasmith being the import plugin for use with various 3D packages… I use it for any realtime and movie walkthroughs.

Anyway, my point was that software such as UE4, which is very actively developed, has this issue where there are conflicts in authenticating licenses with some other programs installed, mainly anti-virus… It seems at least possible that an update to one of your anti-virus programs for example may be giving you issues…?

Is the slowdown with Maxwell Studio solved when you completely disconnect from the Internet and LAN, or just when the Internet is disabled?
By feynman
#397702
Well, ALL other software runs without problems.

Yes, once the laptop or PC has no internet access, things are normal. No internet access = switch off in Windows 10 only or physically disconnect ethernet cable or physically switching off WLAN router. Once internet access is enabled again, back to endless waiting times.
User avatar
By CDRDA
#397705
I wonder then if it might be a windows 10 update that is causing issues? Do you have the latest version installed? Have you tried unistalling Maxwell and doing a fresh install? Graphics card drivers current?

Do you have the same speed issues when the laptop is taken out of the office and using a different WLAN router, or wi-fi connection?

Do you have floating, or node locked Maxwell licenses?

Do you have a spare computer running only windows, or windows 7 and nothing else, that you could install Maxwell onto and connect to your network?

It sounds like a case of narrowing down the possibilities as much as possible… Is it a Maxwell Studio issue, or is it coming from somewhere else? If Studio works fine when connected outside of your network, then there is an issue with your network.
By feynman
#397706
Everything regarding Windows and drivers is up to date. All softwares work perfectly. Apart from Maxwell Studio. License are nodelocked. I have tried office network, home network. Same problem.

I have not dared to wipe Maxwell and re-install it, so I try that next, hoping I get no licensing error as often in the past.
By feynman
#397708
Alright. Wiped everything. No extra antivirus software installed. No extra browsers or "funny stuff from the internet" installed. Windows up to date. Installed latest Studio version 4.2 from the customer portal. Did not install RLM.

Same result. Once connected to the internet (ethernet cable plugged in and internet access/WLAN active and internet access) opening, saving, FIRE, etc. take forever.

This is just terrible.
User avatar
By CDRDA
#397710
That is crazy, but narrows down the issue... When did you start to have the slowdown with Studio- was it with the latest update and was performance hit straight away after upgrading? I would also be tempted to try out the last version of Maxwell v.3.

Can you notice the difference in speed straight away unplugging from the internet, or only after a restart of Studio? Similarly with reconnecting to the network- do things grind to a halt as soon as you plug back in?

What about Maxwell Network Manager/Render Node/Maxwell Monitor- I presume you have these running at the same time? Does the slow down happen when they are closed?

Do you have the really slow performance on just a blank scene, or mainly when you load in geometry?

Sorry for all the questions! Probably pissing into the wind, but may help the devs come up with an idea as to what the cause could be... Studio runs OK for me, apart from not so good viewport performance when geometry is loaded in, but FIRE, opening, saving and so forth is fine. It is rather unstable at the moment though.
By feynman
#397711
Roughly five weeks ago, when we began re-evaluating one more time, if we should keep Maxwell Studio or take the dreaded Keyshot plunge. The software wasn't in use before that for roughly half a year.

When keeping Maxwell Studio open and then disconnecting from the internet, everything is back to normal. When connected to the internet, many of the aforementioned operations become excruciatingly slow again. I can only conclude that Maxwell studio must, in some way or another, interact with internet functionality, when present.

We do not have Maxwell Network Manager/Render Node/Maxwell Monitor running at all.

The symptom arises with an empty file and just a cube or plane from the built-in library also.
User avatar
By CDRDA
#397712
Interesting. Logically, it could be a driver (possibly GPU), or the last Maxwell update did something that seems to react to your internet connection differently to others- not sure what that could be given no one else seems to have mentioned having the same problem... I am at a loss to explain what might be happening, but maybe a Dev, or the Mod could comment further based on the info you have given in the past few threads.
By feynman
#397713
If this is not solvable, I migrate all 50 users to Keyshot. As it is now, it is useless, not even mentioning all other shortcomings collected in this thread. That since a long time these forums see no commenters is telling.
User avatar
By CDRDA
#397714
Well, I hope someone can help you out. I can't imagine how you manage in a production environment with such issues over 50 machines. It would be interesting to know if similar problems happen with any of the Maxwell plugins, but I guess you don't run any software such as Maya, or SketchUP that can test that out… ?

I used to manage 20 computers in a small architectural office and that was bad enough with primarily AutoCAD. Most of my issues were user related rather than software/hardware, although upgrading was always "fun".

You ahould really check out Unreal Engine 4/Unreal Studio with Datasmith before jumping ship to Keyshot. UE4/Datasmith has a plugin for Catia and other sinilar software I believe, although the learning curve is quite steep. The quality that can be achieved is really good, although not quite Maxwell standard of course. Hopefully there will be some integration between Maxwell and UE4 in the near future, especially when Maxwell's gpu engine is fully realised. Not to mention UE4 Studio and Datasmith are free until next year, while they are still in beta… But hopefully you can find sone answers to your Maxwell problems asap… Have you been in touch with customer support through the Next Limit portal?
By LadleSky10
#397716
The computer experts would know better on this but the issues you describe around the internet connection can also result from path settings --and I notice from one of your posts that Dropbox is listed. Have you tried checking your Maxwell Studio path preferences? It could be that Studio is attempting to locate a path on the internet that's no longer valid --rather than a license. No internet connection: it doesn't bother looking for the path. Internet connection: it attempts to find it. Maybe just restore defaults on the path preferences and see it that helps.

Are you using some type of custom startup for Maxwell Studio? Perhaps those settings have invalid paths or something.

Might also try taking a look at the Windows task manager to see what processes are running in the background or starting up. Check both before loading Maxwell and after loading Maxwell. See what's taking up the most system resources.

Have you told Support what your computer specs are? Type of graphics card used, computer maker, memory, processor, etc.. Sometimes there's an incompatibility or something that a driver update might solve (although I think you've ruled this one out).

Are your computers "always on" computers or do you shut them down? Try doing a proper shut down. Often this will offload background programs that have been silently running (which aren't in the startup). If you're using a server you might shut that down for a restart as well (a computer expert here might want to chime in about now on that one!)

And finally, is it possible your installation of Maxwell has simply become corrupted in some way? A clean uninstall followed by a system shut down, maybe a registry cleaner before re-installing . . . I don't know . . . maybe.

Sounds like you're having an awful time of it. Hope something someone here suggests helps you out eventually.
By feynman
#397719
"Have you tried checking your Maxwell Studio path preferences?"

Like I mentioned earlier: New Windows 10 install. Windows 10 updated. New Maxwell install. Again, Maxwell Studio and Material Editor are the only softwares playing foul upon internet connection.
is Maxwell Render abandoned?

Another new GPU video from Facebook: https://www[…]

Multi Light Camera

We have MultiLight which is an excellent post rend[…]

Hello Maxwell people, Is there any sign when Maxw[…]

Maxwell for Rhino 6 / Mac

Hi! We wonder how is it with the development of M[…]