Everything related to Maxwell Render and general stuff that doesn't fit in other categories.
By dvsone1440
#394723
I am experiencing something I don't understand since updating to V4. I render on my workstation and get an expected benchmark. Then I transfer the file to my rendering machine and where I expect it to be significantly faster, yet it is about 3 times slower? My workstation is i7 4770 overclocked 8 core 16gb ram and my rendering machines are Intel Xeon 32 core 16gb ram. These are machines I have been using since 2 with no issues and typically its the other way around my Render machines are obviously much faster due to the extra cores. Is there anything about V4 that could be causing this? A new setting I don't know about? The render machines basically have no video card (I don't remember what they have but not much) I know you can do GPU rendering in V4 but you have to select that correct? Any thoughts would be appreciated. We have new IT as well in our office so I am not sure this is not just some overlord software that is killing those machines, but I am trying to follow any leads I can.
By dvsone1440
#394725
Auto (0) on all machines. On the workstation all 8 cores are at 100% as well as all 32 cores of the two render stations. Doesn't make sense. There is nothing else in the processes for the render machines running either whereas the workstation has a whole lot of other junk running yet is significantly faster.
By dvsone1440
#394726
The workstation is on the left in these images. The render machines middle and right.
You do not have the required permissions to view the files attached to this post.
User avatar
By Mihai
#394727
That is indeed strange. The thing I noticed in the Render options is priority on the render machine is set to Below normal, while on the workstation it's set to low. This shouldn't make that big of a difference though if nothing else is running on the render machines. Would be interesting to see if this happens with any other scene.
By dvsone1440
#394733
I tried fiddling with the priority it didn't seem to change anything. Unfortunately the network license killls maxwell 3 so I can't try the same scene in 3. That said I have tried old renderings that were running at a benchmark of 276 on 3 that If I rerun now have come to a screeching halt on these machines in 4. That's what is so strange the workstations seem unaffected.
User avatar
By T0M0
#394734
What version of Maxwell are you using ? Somehow I didn't see that on your screenshots. Does it happen with latest 4.1.0.4(3) ?
Also you can use Maxwell 3 and 4 on your workstation/nodes if you merge your licenses together. Of course, you can't run them concurrently.

I would try to run render with -nomxi option (in command line) and also without additional rendering channels.
By dvsone1440
#394735
I am using 4.1.0.3 x 64. I did not realize there is a newer one I can try that but am guessing that is not it since the workstations are on the same version and seem to be working fine.

I am not sure what you mean by merging the license. I do know these machines were working well on 3 right before we switched.

I am also not sure what you mean by "in command line" I saw there is a "script" window so I opened that and typed it in and re-rendered after shutting off additional rendering channels. Still benchmark of 8
User avatar
By Mihai
#394736
There is something you can try, to save the MXI files at a longer interval - to check if it doesn't have to do with an abnormally long disk writes, each time Maxwell saves the MXI (at each increment in the render view). In the render options you have a command line input and the command you can use is: -mintime:[min]

So try -mintime:20 for example and it will save only every 20 minutes.

The list of commands you can enter there:
http://support.nextlimit.com/display/ma ... Parameters
By Eduardo G
#394751
dvsone1440 wrote:
Wed Jun 28, 2017 3:31 pm
I am using 4.1.0.3 x 64. I did not realize there is a newer one I can try that but am guessing that is not it since the workstations are on the same version and seem to be working fine.

I am not sure what you mean by merging the license. I do know these machines were working well on 3 right before we switched.

I am also not sure what you mean by "in command line" I saw there is a "script" window so I opened that and typed it in and re-rendered after shutting off additional rendering channels. Still benchmark of 8
Merging a license is: "If you purchase more licenses in the future, you can add the new licenses to your current ones by simply click on the "Add" button and paste the new licenses text. Maxwell will automatically merge your current licenses with your new ones, and save a new license.txt containing all your licenses together. This new complete license file has to be used on all your computers (old and new)."
By dvsone1440
#394769
So we have discovered that this render machine slowdown only occurs when using Maxwell Grass? This was never an issue with 3 as they would run as expected with 3. However all the renderings we have been testing were using grass. They render as expected with our workstations, then when transferred to the Render machines they slow way down. Very confused.
User avatar
By Mihai
#394770
In that case maybe V4 uses Curve grass type instead of the Flat type. Curve can take much longer to render than Flat. Do you have the possibility to open the scene on a workstation with V4 Studio to check?
By dvsone1440
#394771
Sure I can do that, but it does not explain why it would run fine on our workstations, but not on the faster render machines does it? Runs as expected on the workstations. I will check curves vs. flat.
By dvsone1440
#394775
So that was a good call. I switched to "flat" blades and everything worked as expected See attached screen grab with workstation on the left and render machine on the right. Not quite double the benchmark as expected. So that solves my immediate problem thank you very much. That said there is something wonky going on with curved blades in V4.
You do not have the required permissions to view the files attached to this post.
GPU Error

hi, when try to use FIRE GPU in Rhino 6 I get an […]

Low Priority Render Ignored?

Thank you for the workaround. When the render is[…]

GPU Tests

Hi Luis, many thanks for the suggestion, this inde[…]

Hi I always process the scene through Maxwell stud[…]