Everything related to Maxwell Render and general stuff that doesn't fit in other categories.
By Nigel Baker
#18957
Hello Everyone,

Just got my Maxwell for Lightwave on the Mac.
I have installed Maxwell R and I have the 'maxwell R Panel in lightwave.
But that is as far as it goes. When I press render frame the name blinks for a second and nothing else. I know I am missing something but what that something is I do not know.
Please some tips pointers and very specific help is needed here.

Thanks very kindly.
By kingpin
#18985
As lluistar mentioned there was binary incompatibility with g4.(for that see the thread.)

But there is also another possibility of incomplete installation. Have you set MAXWELL_ROOT? If you haven't, you will need to set this param. There are few threads regarding this...(noseman's summary thread: http://www.maxwellrender.com/forum/viewtopic.php?t=1716).

If you need further help, let me know...
By Nigel Baker
#18997
Thanks for the replies,

No I am on a G5 but I shall look into the root issue.
The root issue? I thought since I did not get any instruction from Maxwell (unless I missed it) about this Root Issue I disregarded it. I had seen the thread, but thought it was not for me. I shall go back and check it out. I only just got Maxwell R - and I always feel nervious abouttouching the terminal and the rest.

Thaks again.
By kingpin
#19013
Can you check the log by launching console app in Applications/Utilities?
It should give more detailed info on why and how it failed.

1. Launch LW and setup scene.
2. Launch console and clear log.
3. Try render with Maxwell.

This should give info like no lisence, no Maxwell_root.. etc.

Good luck.

Kingpin
By lluistar
#19015
Nigel,

Don't be afraid, the terminal is your best friend. (It can also wipe out your hard disk completely - but that's the fun ;P )

Maxwell is an application that does not behave like the photoshop or lightwave, it's a comand line application. It does not have an interface with buttons, icons and menus to click to give orders. It needs that you write down in the terminal what do you want the application to do.

All the commands related to maxwell (even if you write them wrong) would not afect anything else than Maxwell, so you are safe there.

Nice thing abot the terminal is that it gives you a feed back of what's going on.

First thing you have to do is to enter this command to the terminal and post the feedback you get
Code: Select all
/Applications/maxwell.app/Contents/MacOS/mxcl
I suposse you install Maxwell inside the Applications folder.

Based on this we'll know better what's your problem
By Nigel Baker
#19017
Thanks chaps for the help.

I ran the line and got the following.

"Last login: Tue Apr 26 09:32:14 on ttyp1
Welcome to Darwin!
Solid-Design:~ Nigel$ /Applications/maxwell.app/Contents/MacOS/mxcl
License not valid. Program aborted.
Check installation rules or re-install the software."
By kingpin
#19022
OK. so you got license issue.

Here are few things you should look into:

1. The license file has to be a plain text file(use cmd+shift+t in TextEdit to convert to plain text).
2. The file has to be named "license.txt"(with extension).
3. The file has to be in the same folder as mxcl (i.e. inside "maxwell.app/Contents/MacOS")
4. The file should contain only license info(remove all empty lines and unnecessary white spaces to be safe).

Regarding "MAXWELL_ROOT," try using "env" command(just type "env" and hit rturn) in terminal. This will display all defined environmental variables, and you should see a line saying "MAXWELL_ROOT=/Applications/maxwell.app/Contents/MacOS/". If not, you will need to set MAXWELL_ROOT...

Good luck.
By Nigel Baker
#19028
Thats briliant Kingpin,

It was the License issue, now it tells me
-------------------------------------------------------
MAXWELL RENDER (M~R) version 1_1_33_0001_alpha_
MAXWELL Console Application version 1_0_1_0001_alpha
(C) 2004 Next Limit Technologies

-------------------------------------------------------

Thats good and the Root is also good.
What is the next step, by the way I really appreciate your help here, even though I am ment to be working on something else. I hope this is not putting you under any pressure.
By lluistar
#19030
Now try to click on any .mxs and see what happens.
It should start rendering.

Second, Try to render from Lighwave.
By Nigel Baker
#19031
Getting Spinning Beachball :(

Also I got an Apple Dialogue Box saying
"Unable to complete this command"

Have to Force Quit now out of Lightwave.
By Nigel Baker
#19033
Have success now.

After Force quitting I double clicked on a .mxs scene file I made yesterday and it is rendering now.

Will try the Lightwave Plugin Version in a while.

Thanks immensley for your help. Your cool.
By lluistar
#19034
Ok, have you tried to double click on a .mxs file?

It would be nice to know if the crash is from the plugin, from maxwell or from lightwave.

Have you remembered to use only maxwell materials and camera?

I don't have lightwave, so I doubt I can help you beyond this point

Good luck
By Nigel Baker
#19035
Thanks lluistar,

You have been a great help.
It is working now I just had to restart and it all kicked in.
Where is the .mxs file saved to.?

I will try the Lightwave plugin now and take it from there.

Thanks again, I really appreciate your help.
By Nigel Baker
#19068
Hello lluistar,

I am following your Unoffical Mac Install but in my downloads I have no
"I used the file caca.mxs that come with the package" (caca.mxs file).

Can you direct me to this file please.
Thanks
Denoiser crashes rendering

This is my 1st attempt at using Denoiser. When I […]

ilgioma on Gumroad

Hi everybody, I would like to let you know that fr[…]

MXM - Anodized Aluminium

Those look great! Good job! Thanks Tim :D L[…]

Rhinoceros 6 support

@greengreen Thanks for your comments; I'll ans[…]