By hwolfejr
#390012
Beta plugin 3.2.3
Sketchup Pro 2016
Windows 7 64bit

When I make a selection from Browse for an MXM file, the material does not load into the material scene manager tab nor the sketchup material as it once did.
I checked my pathing to the network MXM materials in Studio and it appears correct.

Anyone else having this issue?
By JDHill
#390013
I'm not seeing that here, so first, could you please let me know the version of Maxwell Render you are using? And, whether this issue seems related to installing a different version either of Maxwell, or of the plugin.

Then, please go to Scene Manager > Options > Diagnostics and enable Ruby Echo. The Ruby Console should pop up, and you can use it to see if any error message is printed when you then try to browse for an MXM file.

Lastly, please let me know if it makes a difference whether you browse for an MXM in your Documents folder, or elsewhere on the disk (e.g. Maxwell 3/materials database/mxm files -- point being, to try a location where you have a lower permission level), or on the network.
#390014
Maxwell Version 3.2.1.0 Win64
This has occurred since I installed the beta plugin version for Sketchup Pro 2016


Ruby Console:
MX: MXM browsing failed or was cancelled.

We have aggregated our MXM materials to a map network drive so all users can access them.
The browser works fine seeing MXM materials from this mapped drive, see attached image.
I do notice the MXM window says Untitled.mxm - Maxwell Material Editor

EDIT: When I click on a material to import, the Sketchup screen flickers as if it is requesting the material, but doesn't load.

https://www.dropbox.com/s/oqyyu0572jabr ... rowser.jpg
By JDHill
#390015
I'm not having any luck reproducing this yet; I have mapped a drive on my mac to Z:\ on my windows machine, and I'm able to browse and select MXM files from this location (the MXED title also shows untitled.mxm for me -- I guess it just says this when it has not been opened with a particular MXM specified). I am also able to browse for MXMs successfully by using the raw UNC path to the shared mac folder, rather than the mapped drive. I have tried both Maxwell 3.2.1.0, and the current early build 3.2.1.1, with the same result.

So, could you please let me know if there is any case (meaning, as I wrote before, browsing for MXMs in your Documents dir, or in Maxwell 3/materials database) in which it works for you? We need to find a clue that either shows some issue on your end (insufficient permission to access files, weird path characters not being handled correctly, etc), or allows me to reproduce the behavior here.
#390018
https://www.dropbox.com/s/jufoidutpchrq ... 1.jpg?dl=0

First screen is my Search Paths in Studio

Screen two shows Win Explorer network path to folders and ability to access them.

Screen three is Maxwell Material Editor and Browse function.

https://www.dropbox.com/s/raecqp9e1u1mu ... 2.jpg?dl=0

My Documents dir shows in the second image file.
I don't know exactly what you are looking for.

EDIT: OK, I did browse to my documents directory in the BROWSE FOR AN MXM FILE and selected an MXM from the Maxwell\Sketchup\temp\textures folder and it still did not load into Sketchup or the Scene Manager.

Thanks
#390019
In case you didn't see edit to previous post:

OK, I did browse to my documents directory in the BROWSE FOR AN MXM FILE and selected an MXM from the Maxwell\Sketchup\temp\textures folder and it still did not load into Sketchup or the Scene Manager.

When I installed Maxwell 3 onto this new laptop Jan 5, I redirected the materials library to R:\materials database \mxm files.
There is no materials database under the Maxwell 3 folder.
Last edited by hwolfejr on Tue Jan 26, 2016 8:01 pm, edited 1 time in total.
By JDHill
#390020
I am looking to find out whether you are able to browse for an MXM file, from the plugin, if it is located in your Documents directory (where you definitely have permission to access files), or if it is located in the Maxwell 3/materials database/mxm files directory (where, by default, you likely have permission to read, but not to write).

If you cannot do that, then we should try to see what the plugin is seeing on your machine, when it calls MXED. To do this, you would:
  1. Open the Program Files\Next Limit\Maxwell 3 folder in Explorer.
  2. In the directory tree on the left, locate the Maxwell 3 folder.
  3. Hold down SHIFT, and right-click on the Maxwell 3 folder.
  4. In the right-click menu, choose Open command window here.
  5. In the command window that pops up, type: mxed -brwclose
  6. Hit Enter, and MXED should start, in mxm-browsing mode.
  7. Double-click on an MXM file.
  8. MXED should close.
  9. In the command-prompt, you should see some text printed.
This text is what the plugin reads, in order to find out what you selected. The last line printed should start with MXM:, and following that, should be the path to the MXM you chose. Please try browsing to a few different MXMs, in different locations, and see if you find anything odd.
By JDHill
#390023
Unfortunately, I don't see anything wrong with that output, and even duplicating your setup down to the virtual drive letter & mxm path, it is still working fine for me.

So, what else to try... I have not yet asked if you are able to use an MXM by selecting a material in Scene Manager > Materials, switching it to MXM mode, and browsing for an MXM file. So please let me know if that works.

Second, mapped drives can be a bit touchy, depending on the user who created them, and the user who is using them. So, when you browse for an MXM, and MXED comes up, rather than clicking on the R:\ drive in the tree, put your cursor in the address bar at the top and manually type the actual UNC path to which R:\ is being mapped. If everything is okay, you ought to be able to get to the same place that way; the difference will be that MXED will write the UNC path, and the plugin will try to access the MXM (assuming it is getting the path in the first place) using that, rather than the mapped one.

On my side, I'm working on finalizing the next plugin build, so what I'll do is, when mxm browsing fails, I'll just go ahead and print the whole output that MXED wrote, the better to try and debug issues like this.
#390024
The Scene Manager does select an MXM from any folder and I try to assign it to the selected SU object.
It will not assign. The name stays the same material that was last selected in the SU file.
Even the selection of the MXM will not change the material name in the pull down.
Really odd.

My IT guy is supposed to be coming in later today. I tried the UNC, the browser just churns and does not open anything.

I'll keep you informed.
Thanks.
#390025
Hi JD,

My IT administrator verified that the plugin can now now see the UNC.
He set the R: mapping at login from the server, not set by my setup.

The same problem occurs.
I had additional Ruby Console information which I attach:

https://www.dropbox.com/s/anqvywxa2tgrr ... 4.jpg?dl=0

I repaired Sketchup and had reinstalled the plugin.
I can not get any MXM materials into my Sketchup models at this time.

Let me know if you have any further ideas.
Thanks
#390031
Coworkers do not have this problem and they are pulling from the same material network drives.
EDIT: They are using SU 2016 and the beta 3.2.3 plugin.

I had them open my file and insert MXM materials. Some Visual basic or other program has broken.
Does that help you track anything else?

Regards,
Herman
By JDHill
#390032
At this point, I don't see it being a network-related issue, since you said you can't load an MXM when it is located in a local directory. Regarding your mention of Visual Basic, the plugin does not use that, but perhaps some other plugin does; have you already tried temporarily removing all plugins besides Maxwell and seeing if that makes a difference? Plugin conflicts are rarer than often assumed, but they can and do occur.
Let's talk about Maxwell 5.2

"the learning curve and complexity are throug[…]

Materials translucent with V5.1

Well, the problems can be in the chair, the monito[…]

hardware question :)

That’s a point to resolve fast. Other rend[…]

New podcast - CG Talks

Hey guys! We have just finished the second season[…]