By Jodie Jo Jodidio
#383476
Hi there

I am having problems sending an MXS to or opening MXS files within Maxwell Render.

I thought it may have been a corrupt file but have since cut out all of the geometry and MXS Refs and placed them into a new Sketchup document, piece by piece, each time sending a new MXS to render to see if it is one specific MXS ref or piece of geometry which is causing the problem. However I cant seem to find any one specific thing which makes it crash. Fire seems to work fine within Sketchup.

When I open the MXS in render it says that is has been read successfully in the console, but then crashes all of a sudden once I hit the render button. The MXS file is 1.2MB and the Sketchup file is 4.6MB. Is there a limit to the file size which it can manage?

I'm using Learning Edition of full Render Suite V3 with Sketchup Pro 2014 on Mac OSX V10.7.5 2.2GHz i7, 8GB RAM

In a real hurry to get this image done! I thought all was going well as Fire was running fine... last minute panic now!

Any ideas?

Thanks for your time :)
By JDHill
#383477
Hmm, there is a known crash with MXS references that contain instances, in the most current builds (Maxwell 3.0.1.3, plugin 3.0.15), but if you have removed all MXS references, that would not seem to be the problem.

My first guess would be that it could come down to a corrupt texture, so I would recommend manually deleting both the "textures" folder next to your exported MXS file, and also the ~/Maxwell/SketchUp/temp folder, and trying to render again. That would not guarantee all textures to be replaced though -- only those contained in the SketchUp model itself, which are written to disk on demand. So, it would also be necessary to check textures referenced by MXM files.

If that does not help, please send (by zipping & email to jeremy at nextlimit dotcom, or by uploading to dropbox/onedrive/etc) me the SKP file, and any referenced MXMs & textures, so I can try to reproduce the problem here. Also please let me know exactly which versions of SketchUp, Maxwell, and the plugin you are using.
By Jodie Jo Jodidio
#383478
Hi, thanks for getting back.

I'm not sure I follow you exactly. When you say MXS references which contain instances, do you mean that contain nested MXS references, or Sketchup components maybe? I'm not sure what else you mean as I know you cant have MXS refs with nested MXS refs.
I have rebuilt my file and placed back in some of the MXS references I was using. Up to a point it sends to render fine, and then on the addition of other MXS references it crashes it. However I've tried rendering these MXS refs separately and they work OK, so I cant pin point a specific thing which is causing the problem.

So, I have deleted the textures folder next to the exported MXS file, but I'm not sure where to find the ~/Maxwell/SketchUp/temp folder you mention? I'm not sure how to check for corrupted textures within Sketchup or Studio. I'm actually trying to avoid having to learn Studio as it looks like a whole new can of worms I dont really have time for! If I can do things in Sketchup and then send to render without having to deal with Studio, so much the better (for now, anyway!).
Anyway deleting that folder hasnt worked so if you can tell me where the other one is, I will try that next... Thanks :)

I'm using Sketchup 14.0.4899,
Maxwell Render Suite Plugin Version: 3.0.11
Maxwell Render 3.0.1.0
Mac OSX v10.7.5 2.2GHz i7, 8GB RAM
By JDHill
#383481
If you export an MXS from SketchUp with Scene Manager > Output > Export > Instances enabled, then the MXS will likely contain instances, and these may cause Maxwell to crash. However, as you are not using the affected versions, this should not be the cause of the trouble.

It could be something else, though, such as running out of memory, due to a particular material using pretesselated displacement. That could be the case for an MXM referenced in the SKP file, or in a referenced MXS file. However, that should be more of a problem in FIRE than in Maxwell, since SketchUp is 32-bit (and will therefore run out of memory in the 3GB usage range), and Maxwell isn't. So this doesn't seem likely to be the cause.

On a Mac, "~/" means the Home folder, meaning /Users/<username>. Inside, you should find a Maxwell folder, and the SketchUp/temp folder I mentioned above, inside that. I also doubt deleting this to make a difference though, especially since you say FIRE works fine.

So basically, at this point, I can't yet help very much. When Maxwell crashes, does OSX put up an error-reporting dialog? If so, please paste the text, in case it could help point to the problem.

I do recall there being an obscure issue with some materials (using anisotropy, I think) in 3.0.1, so you might also try updating to the most current builds (from here), to see if you are running into an issue that's already been fixed in a beta. In that case, though, keep in mind again the issue I mentioned with MXS references crashing when they contain instances, and that you would need to re-export the referenced MXS files with Instances disabled.
By fv
#383584
I am crashing Maxwell exporting as well with instances disabled with version (Maxwell 3.0.1.3, plugin 3.0.15) using mxs references.
Can I just install Maxwell 3.0.1.1 and get the job done ?

I depend on MXS references in Sketchup. Can't really explode those or import the geometry in my SU file.
Any other solution ?

tx Francois
By fv
#383596
Tx JD.
I converted the instances to mesh in Studio and things render fine now. Hope this issue is resolved soon.

I noticed that the right click Maxwell menu "open in Studio" for a reference no longer works.
Francois
By JDHill
#383600
I would guess that to mean that in updating the Maxwell installation, the file association for .mxs files is no longer pointing to the right location. I would recommend emptying the trash, rebooting, and then making sure that mxs files open in Studio or Maxwell when you double-click them in Finder.
By Jodie Jo Jodidio
#383642
Back again...

This time, I really am completely at my wit's end with trying to understand what is going on.

Maxwell Render continues to crash, after I have completely wiped my entire OSX and reinstalled everything, deleted materials folders as you suggested and made sure there are no instances contained in any MXS references.

I have taken my model apart, and reconstructed it bit by bit, and exported to render at every stage. I actually managed to completely reconstruct the file and for a minute the completed file WORKED! I was feeling very encouraged... but after another test 5 minutes later it crashed again. All I had done was rotate some of the geometry which was already placed within the model and saved it - so at this stage I am completely baffled as to what is going on.

I imagine if I send you my files you may not be able to reconstruct the issue as it has sometimes worked. So I cant see how it could be a corrupt material or instance issue, but perhaps you could try anyway. What's the best way to send it to you?

If I reverted to Maxwell V2 and a previous plugin version (perhaps a solution?), do I need a different license code?

Desperately...

Jodie
By JDHill
#383643
I really can't speculate, all I can do is look at your files and try to reproduce the issue. It is probably best to use dropbox or similar to send them.
By JDHill
#383645
You can post a link here, or by private message if that is more appropriate. Or, if you prefer, you can send it to jeremy at nextlimit dotcom.
By JDHill
#383647
Good, I'll take a look as soon as I get to the office tomorrow morning. In the meantime could you please let me know which versions of Maxwell and the plugin you ended up installing?
hardware question :)

I can easily create an usable render in 15/20 mi[…]

Maxwell for Rhino on Max missing Toolbar

Hello, For some reason, the Mac version of Rhino[…]

Let's talk about Maxwell 5.2

Price for sure matter a loot. Speed is the core i[…]

Materials translucent with V5.1

Well, the problems can be in the chair, the monito[…]