[img]I am using the payed Maxwell Rendering plugin for Sketchup.

I am attempting to light up an interior.
However, I am getting significant dots/grain/noise even
after 12hrs of rending time (about 19sl).

My settings...

Environment- None

Camera - EV 1
fStop - 5.6

Material - 0128 White [color of my emitter]
Scene - emitter ies
Type - emitter
Watts - 70
Eff - 43

So when I hit render it looks proper except for the super high level of graininess

I need help! Any advice?
Could you please post an image (it looks like you may have tried -- you need to upload it to imageshack or similar, then put the link between [img][/img] tags). That aside, the first thing would be to make sure that in the Maxwell Fire window, when you are rendering a final image, that you have set Settings > Engine to Production; the Draft engine is good for working with the scene, but the Production engine is better for rendering final images. Secondly, a camera EV of 1 sounds pretty extreme, though it's not possible to say for sure without seeing the scene.
Thank you soooo much for responding, I have a Friday deadline and I am worried.

This is the grainy image.

I did fire in Draft engine mode opposed to Production. If I fire in Production do you think this will reduce the grain?
Do you think I should increase my EV?

Your advice is VERY valuable. Thank you!!!
Thanks for posting the image -- the Production engine should indeed greatly improve the performance in this situation.

Regarding EV, the reason for mentioning it is that for a scene like this, I would generally expect it to be more in the 6-8 range. The fact that you need to set it so low tends to indicate a lack of light in the scene, which might mean there are too few lights, that the ones that exist are using unrealistically-low wattage, and/or that the scene is modeled at an unrealistically-large scale. If the emitters are using IES files, it could also possibly indicate problems with those files, so it might not be a bad idea to do some experimenting with not using IES, comparing the power output with & without.

Which is to say, it is not so much that you will just change the EV to magically fix things, but more that you can use it as an indicator that something might not be set up realistically. It is no different than if you were shooting this scene in real life with a normal camera: the need to use a radical exposure might tend to indicate that there is some problem with the lighting -- the wrong bulbs are installed, and so on.
Here are some screen shots...

Emitter Material


EV now at 7
Environment - Still None
Should I change anything in the Output tab?


Will this image brighten as it renders, or are there not enough
watts at 85 or are there just not enough lights?

Is it typical for a rendering like this to take 15-18 hrs to finish?

Thank you!
Sorry, didn't look like the images attached the first time...

Emitter Material


EV now at 7
Environment - Still None
Should I change anything in the Output tab?


Will this image brighten as it renders, or are there not enough
watts at 85 or are there just not enough lights?

Is it typical for a rendering like this to take 15-18 hrs to finish?

Thank you!

Looking much better with the production engine. You should not need to change anything in the Output tab, except to disable Simulens features (if they are enabled), if the aim is to reduce render time to the absolute minimum. One more important thing to mention here regards the Maxwell Fire Settings window again, and that is the Threads setting: 0 threads means that Maxwell will automatically check how many threads (that is: CPU cores * threads per CPU core, so typically 8 threads for an Intel quad core with hyperthreading) are available, and use them all. Otherwise, you can set the desired number, in case you want to keep working on the machine while rendering (using all threads will tend to bring the machine to its knees).

Regarding the overall brightness of the image, I will make the assumption that most of these lights are meant to be fluorescent, in which case the Efficacy of 12.7 is likely too low. For example, wikipedia indicates (here):
wikipedia -> fluorescent lamp -> luminous efficacy wrote:The efficacy of fluorescent tubes ranges from about 16 lumens per watt for a 4 watt tube with an ordinary ballast to over 100 lumens per watt with a modern electronic ballast, commonly averaging 50 to 67 lm/W overall.
It will not be an exact science, unless you have manufacturer data on the lights, but you can use information like this as a guideline. Aside from that, with the production engine, I would not pass judgement on the lighting of a scene like this until around at least SL8 or so -- it can be a good idea to drastically reduce the output resolution and render a test, if there is any question. However, with camera and lighting using realistic values, that should not usually be necessary.

As far as render time to finish is concerned, I would not expect this scene to take that long, though it is not possible to say, without knowing about the machine, and the number of threads being used for rendering. Regardless though, it may be worth mentioning, what I'd generally recommend once you are ready to render the final image is to:
  1. Set Maxwell Fire Settings > SL to a very high value (25-30), to prevent Maxwell from ever stopping on its own.
  2. Use all threads and leave the machine alone, in order to allow Maxwell to take full advantage of the hardware.
  3. Engage the "Lock" toggle-button in the Maxwell Fire window, to prevent inadvertently restarting the render.
At this time, all that the "Extensions" switch does is turn Maxwell Grass on/off on a global basis, so it will not likely change anything in this scene. Regarding IES emitters, judging just from your screenshot of the material editor, you are not actually using any IES emitters. The "Scene" dropdown, where you've selected "emitter_ies" simply selects which scene you would like to use for previewing the material; that one is designed for previewing emitters which use IES files. To actually use an IES file, you would choose the "IES File" material Character, rather than the "Emitter" one, in Character > Type, and then browse to the desired IES file (you can find a collection of these in your SketchUp plugins folder, under maxwell/res/ies).

My guess (meaning I have not done a benchmark) would be that in general, IES emitters will tend to take somewhat longer to render, though it depends on whether we are comparing to mesh-based emitters with many faces (many triangles in the mesh), since that tends to increase the render time. Regardless, the most efficient emitter in Maxwell would be a single triangle with a simple emitter material assigned.
I am not entirely sure what you mean by "transparent Sketch-Up fills," but the answer would have to be: with a material, since that is the way of making anything anything in Maxwell. I would probably recommend experimenting with some of the different material Character types:
  • Liquid & Glass: Use these with volumes only (due to refraction: if you make a single face glass, light enters, but never exits).
  • AGS (Architectural Glass Solution): This is basically a mix of mirror and vacuum, the point of which is to yield reflections like glass, without the cost/complication of refraction.
  • SSS (Sub-Surface Scattering): For rendering volumes (as with liquid/glass), where light does not simply pass through, but also interacts with matter inside the volume, as with wax and such.
  • SSS Single-Sided: Similar to SSS, but able to be used on single-thickness faces; typically used for leaves, curtains, etc.
  • Complex IOR: This uses a file (a collection may be found in maxwell/res/ior) containing actual measurements from real world materials, and can be quite expensive (in terms of CPU) to render. Liquid & Glass (called "dielectric") types must also only be applied to true volumes.
Additionally, the Automatic type will also produce an AGS material, if certain criteria are met in the SketchUp material settings (at least semi-transparent, with a color above a given brightness). This is not entirely predictable, though, and is only done because we need to have a default behavior that will try to render glass (well, AGS) where people are using it on their models, even though SketchUp gives us no way of knowing whether that's what they really want, or not. So if there is any question, you should take control and choose a specific material Character. For more information on the material Character types, and their parameters, please see here (or the PDF manual included with the plugin).
This information (texture UV coordinates) comes from SketchUp, and is therefore done as it normally is done in SketchUp: assign a texture (most likely the predominant one in use in the MXM) to the entities in SketchUp, and use right-click face > Texture > Position.
justin nixon wrote:Success!!! Thank you very much!
Sorry for dragging this back. I stuggle with the same issue, more or less. I'm at EV 5-7 in my scene and still get a pretty noisy image even at decent SL. What did you do to end up with the final rendering? Just dump light on the problem?

Great, that is good news. Currently I cannot figu[…]

hardware question :)

I can easily create an usable render in 15/20 mi[…]

Let's talk about Maxwell 5.2

Price for sure matter a loot. Speed is the core i[…]

Materials translucent with V5.1

Well, the problems can be in the chair, the monito[…]