By florianpiento
#342931
hi,

I've been running some workflow tests in order to prepare for a animation short film production on Maxwell and I ran into a few problems/incomprehensions.

1) When I import my MXI sequence and either apply directly the MXIextractor effect or use the "create MXI comps", my fresnel and shadow passes appear black/empty, while when opened in Maxwell they appear normally.

2) In the Maxwell Render V2 Manual page 81-83 you can find the different passes rendered separately and at the end the "final composition". Is this "final composition" just a copy of the Render channel or is it a real composited image ? if so, could I have more informations about how it was done ?

3) Maxwell has the possibility to output a Z-buffer pass, but since the camera blur in embedded in the Render channel what was the purpose of this pass ? or is there a possibility to separate the camera blur off diffuse+reflection channel ?

4) I found in this post the uses of the fresnel and roughness passes :
http://www.maxwellrender.com/forum/view ... esnel+pass
but I can't see how in after effect you could "isolate" the reflection with the roughness pass or "select" the glancing angles with the fresnel pass. have anyone used these passes in their productions ?

thank you
User avatar
By Mihai
#342947
I don't know about the AE issues but about the Z-buffer and compositing:

The Z-buffer is used in case you want to apply your own DOF in post using a plugin. You can "remove" the blur from the Maxwell render by setting a very high fstop, like 22 or more depending on how small the object is, focal length etc. You can compensate the change in exposure easily by using auto exposure.

About the compositing you can find more information on the forums but the most basic one is cutting out the main render channel using the alpha channel, then putting the shadow channel on top and setting it to Multiply mode. The fresnel/roughness channels can be used as selection masks for example if you want to tint a reflection, or increase/decrease its strength (for example copy the reflection pass, assign the fresnel channel as its mask, now it will influence mostly the edges and you can further control it with the copies layer opacity).
User avatar
By Brany
#342948
florianpiento wrote:
1) When I import my MXI sequence and either apply directly the MXIextractor effect or use the "create MXI comps", my fresnel and shadow passes appear black/empty, while when opened in Maxwell they appear normally.
What version of maxwell do you use? You use windows or mac? CS4 or CS5? The more info I have, the more I can help! :)
#342969
Mihai wrote:The Z-buffer is used in case you want to apply your own DOF in post using a plugin. You can "remove" the blur from the Maxwell render by setting a very high fstop, like 22 or more depending on how small the object is, focal length etc. You can compensate the change in exposure easily by using auto exposure.
Do two separate renders with a different fstop... I should have thought about it ! i just made a quick test.
straight from maxwell=
-awesome camera blur and grain
-no control in post (easy&quick focus animation etc)
two render with different fstop
-a bit longer render time
- control in post

If the project allows it I guess it just better to do everything in maxwell.

thanks a lot for your advices Mihai !
Brany wrote:What version of maxwell do you use? You use windows or mac? CS4 or CS5?
I'm using OSX 10.6, Maxwell 2.5.1 and AE CS5. made another test with simple cubes. still doesn't work. weird...
#343175
I just downloaded and updated the new AE plugin for OSX.

checked the MXI in Maxwell = all channels ok
in AE :
-put the MXI in the timeline = works fine (render channel displayed normally)
-apply MXI extractor = all channels black
-file=>create MXI comp = all comps black ( is there a reason why it has moved from Composition to Files menu ?? )
-preview bug. when displayed in integral quality works fine but half, third, and quarter quality the display is all buggy.

Is there something wrong with the new MXI extractor ??
User avatar
By Brany
#343186
Oops, the problem was in 16 and 32 bpc projects. Just fixed. You can download the installer updated. Sorry for the inconvenience!

What happens exactly with the preview? I have problems with third (not half or quarter), AE show the upper left part of the image. Is that the problem?

PD: "Create Maxwell MXI Comps" was moved to file menu because other plugins (i.e. Pro EXR) have its equivalent layered comp creator there.

Saludos!

Hi again dear customers, In the version we upload[…]

Hi all, I'm sure this is more simple than I'm mak[…]

Hi, You can create it in the MXED and then use th[…]

Maxwell and Blender

Blender 2.9 is out - has there been any further pr[…]