#391585
something should be wrong with your modo settings the plugin doesn't overwrite the main menu settings for sure.

Please try to remove the modo config file from

C:\Users\<user name>\AppData\Roaming\Luxology

the name of the config file depends on the modo version. For example the config file for modo 901 is MODO901.CFG

this config file can contain your custom settings, in this case it is not so good idea to remove it. But please try to remove it temporarily and check if the problem still persist or not.

Márton
#391592
which version of modo is it?

do you have installed other version of modo to test it with?

this is the command which opens the modo preferences:

layout.createOrCLose cookie:Preferences layout:{Preferences Editor_layout} title:{@macros.layouts@Preferences@} width:645 height:655 persistent:1 open:1


What happens if you copy this command into the modo command panel? (you can find it at the bottom right corner of the modo window)

As a reference this is the command to open the Maxwell plugin preferences:

layout.createOrClose maxwellPreferences {modoAndMaxwell_preferences_layout} open:? title:{Maxwell plugin for Modo - Preferences} width:[550] height:[400] persistent:[1] style:palette


What is the window title of the up coming Preferences window?

Márton
#391593
Hi, thanks for going through this.

this is version 10.1

Also tried 701 and there all goes well, it opens modo's preferences.

In 10.1 when I enter this command in the command panel:

"layout.createOrCLose cookie:Preferences layout:{Preferences Editor_layout} title:{@macros.layouts@Preferences@} width:645 height:655 persistent:1 open:1"

it actually shows the right Preferences window, of modo itself.

Image

The other command:

"layout.createOrClose maxwellPreferences {modoAndMaxwell_preferences_layout} open:? title:{Maxwell plugin for Modo - Preferences} width:[550] height:[400] persistent:[1] style:palette"

doesn't do anything....
#391595
Ohhh, so you open the Preferences window from the modo > Preferences... menu - I was trying the System > Preferences... menu

now I can see it. - thanks for the screen record.

It seems modo collects the menu items into the Modo menu by the names, and the Maxwell plugin also had a "Preferences..." menu point.
It will be fixed for next update, until that please use the System > Preferences menu.

Márton
hardware question :)

I can easily create an usable render in 15/20 mi[…]

Maxwell for Rhino on Max missing Toolbar

Hello, For some reason, the Mac version of Rhino[…]

Let's talk about Maxwell 5.2

Price for sure matter a loot. Speed is the core i[…]

Materials translucent with V5.1

Well, the problems can be in the chair, the monito[…]