By hwolfejr
#393336
Two images and the Sketchup Pro file in Dropbox:
https://www.dropbox.com/sh/p2wrbfrs4vra ... p7rba?dl=0

J.D.

I've installed Maxwell Render 4 with the Sketchup 4.0.1 plugin in Sketchup 2016 Pro.
Once I export the MXS to render, I get exploded and missing objects as shown.

This happened on my computer with the V2.0 to V3.0 transition too.
I can't use MW until this is fixed. Anyone else having this problem?

Herman
By JDHill
#393337
I'm not having any luck reproducing this so far, but there is some ambiguity, so I'll ask:
  • 1. What do you mean, exactly, by saying "Maxwell Render 4" and the "Sketchup 4.0.1 plugin". The reason for the question is that the 4.x plugin bundles its own copy of Maxwell Render. Please start a render, then open Task Manager, go to Processes > Apps > maxwell (v120-intel), right-click > Open File Location, and confirm that the maxwell.exe that is running is the one bundled inside the plugin. If so, then when you click Help > About Maxwell Render in the Maxwell Render main menu, it should indicate 4.0.0.8 for the version.
  • 2. In the plugin, what is the value of Scene Manager > Options > General > Cache Policy? Does the behavior remain if you make sure this is set to Invalidate?
By hwolfejr
#393483
JD,

I was using past program terminology.
I downloaded the Sketchup version and 3DMax version.

My Maxwell Render is version 4.0.0.6

My cache WAS set as Invalidate

I downloaded and installed the plugin version 4.0.3

The same exploded view as before is rendering.

Do I need to uninstall and reinstall a newer downloaded version of Sketchup Maxwell Render?

When I run FIRE, it renders properly.
By JDHill
#393488
If you are using the 4.0.3 SketchUp plugin, then when you click the Render button in the plugin, once Maxwell Render starts, if you then click Help > About Maxwell Render, it should indicate that it is version 4.0.0.11. If you look in the Console panel in Maxwell Render, near the top, you should find something like:
Code: Select all
RUNTIME INFO 
Root dir: C:\ProgramData\SketchUp\SketchUp 2016\SketchUp\Plugins\maxwell\bin\win 
The maxwell.exe that is running should be running from this directory (which you also can check, as I wrote above, by right-clicking maxwell (v120-intel) in Task Manager > Processes > Apps, and choosing Open File Location).
By hwolfejr
#393493
Rendering within Sketchup 2017, my version of Maxwell is 4.0.0.11 x64

Here is the Console panel:
C:\ProgramData\SketchUp\SketchUp 2017\SketchUp\Plugins\maxwell\bin\win

When I export the maxwell file within the plugin to our common network location, I run the Maxwell Render from the desktop and list HELP>About:
The version is 4.0.0.6 x64
The location of the desktop Maxwell Render green icon is:
"C:\Program Files\Next Limit\Maxwell Render 4"

Rendering this has the model exploded error.
I downloaded the model and render image within Sketchup to the DropBox.

The order of installs was Sketchup install then 3DMax install of the EXE files I downloaded for the 2 versions I selected during upgrade.
Last edited by hwolfejr on Thu Dec 01, 2016 7:22 pm, edited 1 time in total.
By JDHill
#393494
I believe, that in addition to SketchUp and 3dsmax, you have at some time also installed the standalone Maxwell package, as this is what would be giving you the installation you are finding at C:\Program Files\Next Limit\Maxwell Render 4. This would show up in Programs and Features as "Maxwell Render 4". Either you need to uninstall this and use the Maxwell Render that is bundled with your plugin (in the case of SketchUp, located at C:\ProgramData\SketchUp\SketchUp 2017\SketchUp\Plugins\maxwell\bin\win), or update it to version 4.0.0.11 from the early builds page.

That said, what remains unclear is:
  • 1. You indicate the render is okay in FIRE; is this true for the Draft, Production, and GPU engines? When checking this, make sure to a) click the Stop button, b) click the Settings button, c) change the engine, and d) click the Re-export button to start rendering again. This is to rule out any potential issues due to switching engines while rendering.
  • 2. You indicate that while the render is okay in FIRE, it is not okay once sent to Maxwell Render. But, at this point, there are two versions of Maxwell Render in play: 4.0.0.11 bundled with the plugin, and 4.0.0.6 installed separately. It is not clear to me whether the issue is showing up in both 4.0.0.6 and 4.0.0.11.
  • 3. I would like to know what happens when you change Scene Manager > Output > Engine > Engine to Draft (and/or GPU), and then render in Maxwell Render (whether 4.0.0.6, 4.0.0.11, or both).
  • 4. I would like to know what happens if you disable Scene Manager > Output > Export > Use Instances.
By hwolfejr
#393496
JD,

Item 1. The Draft and Production engines work fine and the model is correct. The GPU gives the following error:
1. GPU error: Invalid memory address.
2. startRender returned -1.
A bugsplat occurs.

Item 2. I do believe the error is in version 4.0.0.6. I only get incorrect renders when I export the file and render from the desktop icon.

Item 3. I get an Nvidia kernal crash when I set the export to GPU.
I exported my display device driver info to the dropbox.

I have downloaded Maxwell 4.0.0.11 and will install it now.

I have a DELL Precision M6800 laptop workstation, i7-4940MX @ 3.10GHz 3.30 GHz
32 GB RAM
Windows 7 Pro Service Pack 1
By JDHill
#393497
I can't tell you much about the GPU crash, except to say that I am on a very similar machine to you, an m4800/4930mx/K2100m, and I cannot much use the GPU engine because it crashes due to lack of GPU memory (only 2GB on this card). You should be able to check whether you're dealing with the same issue by reducing the Max Res. in Fire Settings to a very low value (say, 320px) before rendering with the GPU engine.

Otherwise, it does sound like the issue is related to Maxwell 4.0.0.6, and that things should be working once you update to 4.0.0.11.
By hwolfejr
#393501
JD,

Good to correspond with you again.
We did track down the initial problem and solve it!
Updating the Maxwell.exe to 4.0.0.11 x64 worked and I can now render using the desktop Maxwell Render and the model renders perfectly.

As you have stated, the setting the output>engine>GPU will crash my computer immediately, no matter what Max Res I set it to.
The error is as follows:

NVidia OpenGL Driver
Unable to recover from a kernel exception.
The application must close.

Error Code: 3

Would you like to visit http://www.nvidia.com/page/support.html for help?


Hope this helps the programmer guys. I know DELL has no later video driver than November 2015 for this computer.

Warmest regards,
Herman
By JDHill
#393503
I guess that means you may be running the 353.82 driver (you can find out the NVIDIA version by right-clicking the Desktop > NVIDIA Control Panel > System Information), which does not support the 8.0 version of CUDA used by Maxwell. It is supported by the current WHQL 375.86 driver available from NVIDIA's website. Of course I can only give you this information, and not actually advise you on maintaining your hardware/software.
Material Editor Help

If you have multiple material Layers and some of t[…]

Thanks Luis, it's great to see progress with MW!

Thanks Fernando!

Attic

Hi, https://www.janwalter.org/assets/attic_maxwe[…]