By acrighton
#389010
Hi!

I just updated my Rhino plugin to 3.2 and have many issues. After installation, I get the "Preparing Plugin for 1st use" message and Rhino hangs and "Name of file to open" is on the command line and locks up. Rhino 5 reports:

Description:
A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: Rhino.exe
Application Version: 5.12.50810.13095
Application Timestamp: 55c9196b
Hang Signature: 83c5
Hang Type: 0
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Hang Signature 1: 83c513da09eac7a695377990b26fe022
Additional Hang Signature 2: 9418
Additional Hang Signature 3: 9418d98323608e759285a5162038f0b7
Additional Hang Signature 4: 83c5
Additional Hang Signature 5: 83c513da09eac7a695377990b26fe022
Additional Hang Signature 6: 9418
Additional Hang Signature 7: 9418d98323608e759285a5162038f0b7

Then.... starting Rhino up again, it locks up at the "Preparing viewports" as it attempts to start, I close the Rhino startup screen and its back to the "Name of the file to open" message and it locks up.

When I unistall Maxwell Render plugin, Rhino is back to normal, reinstalling the 3.1.3 plugin and I get the exact same issue again. I ended up installing the 3.0.0.0 level plugin and it's back working, though I'm unsure if using the latest Maxwell version with the 3.0.0.0 plugin will cause problems? Customer download area only allows you to download latest revision of the plugin, how can I obtain the 3.1.2 revision that was working OK?
By JDHill
#389015
I'm not aware of any such issue, or how to reproduce it, but in the meantime, interim versions of the plugin remain available from the early builds page, so at least you can try downloading the 3.1.2 version again to see if that works. From the error report you posted, it appears you are using Windows 7 Pro x64 SP1, but could you also please let me know whether this is a native Windows installation, or possibly one running in a virtual machine such as Parallels.
By acrighton
#389027
Hi JD,

I tried a few of the downlevel plugins and they're all exhibiting the same issue for me, except for 3.0 ???? Everything was fine until I attempted to install the 3.2 plugin. This now leaves me in a serious problem, materials I used on a daily basis can now no longer import into Maxwell. I'm now unsure if the issue is Maxwell related, or my Rhino installation has become corrupted? Any guidance what to do here? Should I go through the painful exercice of uninstalling everything and then reinstalling both Rhino and Maxwell?
By JDHill
#389028
Unfortunately, I have neither any guess as to what might be causing the problem, nor why the 3.0 plugin would be working. My instinct would be to look at the default template file you're using; perhaps it would be possible to uninstall the plugin, start Rhino, set a different default template (File > Properties > Rhino Options > Files > Template Files > Default), and then try installing the 3.2 plugin again. Also, since it seems to be hanging up during the splash screen, you might try renaming the C:\Program Files\Rhinoceros 5.0 (64-bit)\System\RhinoSplash.dll file (to .dll.old or something), just to remove that from the equation.
By acrighton
#389034
JD,

I tried unistalling/reinstalling both Maxwell and Rhino, still no success. I get to the preparing plugin for 1st use window and it hangs. Subsequently, after a few minutes it starts up (unexpectedly) and on the command line it states:

"Maxwell: Add/Remove Programs to uninstall the program, before reinstalling. If you continue to receive this error after installation/reinstallation, please contact Next Limit support". Close and restart Rhino and it hangs on the splashcreen for a few minutes, then hangs again at the "Name of the Rhino template file to open" on the command line.

I change the default template file, rename the spashscreen dll, uninstall and reinstall Maxwell plugin (3.2), and it hangs on startup. Restart Rhino and it gets to the main screen this time, try to open any file and it wont open anything.

Back to Render 3.2 and plugin 3.0 and it at least works. I reached out to McNeel Rhino forum also for any help... unsure if this is an issue with the plugin or with Rhino...I'm just a simple user...maybe 3.3 will work for me :-)
By JDHill
#389035
When you say you reinstalled Maxwell, you are referring to the plugin only, correct?

The reason I ask is that at least there is some new clue in this last post: the message being shown is one indicating that the plugin is unable to find Maxwell Render on the machine. This should not produce the behavior you describe (the plugin should be perfectly happy to run with no Maxwell Render installation at all), but at least it may point to the possibility that your Maxwell Render installation is not in order. So please try reinstalling Maxwell Render (not the plugin), and confirming that afterwards, you have a system environment variable (for info on this, please see the "MAXWELL3_ROOT environment variable not found" topic here) for MAXWELL3_ROOT, and that it points to your Maxwell 3 installation (by default, C:\Program Files\Next Limit\Maxwell 3).
By acrighton
#389248
Hi JD,

Sorry for late response, I had projects to complete and had to run with the 3.0 plugin to get them done. I reinstalled the 3.2 plugin, checked the environment variables and all appears to be in order, but exact same hang-up occurs. I'm back to using the 3.0 plugin as it works OK for me on this installation. I'm going to stick with this combination for now as it's working for me without any glitches. Thanks.

Hi Guys... Just updated Rhino to Maxwell plugin V[…]

SketchUp 2021 Update

Hi there! Sorry, it is the obligatory post relat[…]

Keep in mind that AVAST actually block anything re[…]

Maxwell and Blender

Thanks for looking into this - hopefully you get w[…]