User avatar
By greengreen
#382281
I've been struggling with real scale on certain types of geometry. The two images below are extrusions from "L" shaped curves.

The two materials applied are lap siding with 4" exposure. You can see that they are different. This seems to be because real-scale doesn't like extrusions, if I explode the extrusion to get two surfaces, the texture looks like it is the right scale, but my displacement material is no longer continuous around the corner.

So, how can I get realscale materials at the actual size on polysurfaces?

Also, using "ctrl + Shift" doesn't seem to work for me to get the "meters" XY repeat scale applied to all images uniformly, is it working for everyone else?

Image
User avatar
By greengreen
#382282
I also seem to be having trouble with a corrugated metal displacement material I just made.

I created both surfaces seen here with a closed planar curve. For some reason the 2 surfaces show the mapping differently. Here is a link to the Rhino file http://we.tl/snoLPvEECF

Image
User avatar
By greengreen
#382294
I figured out that if I create a mesh with high poly counts, rather than a surface, I don't have to subdivide my material so much ( I had it upwards of 200 or 400). Is there a way to define meshing of my surfaces when I export? It would be nice to limit it to geometry with displacement textures so I don't have to increase everything in the scene
By raja
#382302
I haven't tested displacement, but everything from Rhinoceros is meshed for export to Maxwell, based in Rhinoceros document mesh settings. Mesh settings are in Options>Document properties>mesh. Also, you can specify custom render mesh settings for object in object-properties panel.

hope this helps.
By Polyxo
#382305
If your geometry is that simple I would suggest to create them as mesh planes directly, each with considerable (identical)subdivisions and join them together.
That way you can avoid triangles in the join areas which always occur on Nurbs. Then simply use Catmull Clark displacement with low subdivision settings.

PS: I see that your thread title is Real Scale issues - my comment was meant as a general displacement hint. I don't use real scale and don't recommend using it.
By JDHill
#382313
I have also seen various meshing issues with extrusions. Regarding per-object meshing, as Raja says, this can be done using Rhino's Object Properties > Render Mesh Settings > Custom Mesh. Regarding your test scene, I took a look, but am not sure about the effect you refer to, since it was just the 3DM, with no textures. I can try more to reproduce it here tomorrow (have been out of town this week).

I am not seeing any problem with using CTRL+SHIFT with the texture Units parameter; I drop down the list, hold CTRL+SHIFT, and select the desired mode, which is set in all textures in the material.
User avatar
By greengreen
#382411
I regret putting two questions in the thread, sorry for that.

Regarding the real scale, I think I have the workflow wrong, but it works for me most of the time. If I put the material image channels to 0, I cannot rotate the texture using the maxwell object properties "RS Rotation". Below is a Rhino and Fire screenshot of the issue. My base geometry is almost always surfaces.

Image

So what I do is set my real scale texture channels to 1, and then if the scale of the texture is wrong in my rhino work environment, i hit the little "reset" button on the RS Rotation, and it usually scales to the right size, and then I can rotate it. This doesn't seem to work for all geometries though. Works fine for a simple surface, but it doesn't like polysurfaces or extrusions.

Image

As for the displacement, I have modeled my geometry for now. I will experiment on my next project with displacement again, I'll look into the meshing options suggested, thank you for the tips
By JDHill
#382423
Thanks, it looks like there is something going wrong with the RS Rotation feature, though for me, it is on a plane where it's not working correctly. It's implemented using a pretty roundabout hack (objects in Rhino not actually having any concept of local coordinates), so it is always subject to acting strangely or breaking due to unknown factors outside the plugin's control. The only reason I haven't removed the feature entirely is that it can sometimes be pretty useful...but still, I don't like it, and wish I'd never implemented it. If you want the most consistent behavior, I would recommend using explicit mappings, with the standard "Relative" texture mode in your Maxwell textures.
User avatar
By greengreen
#382435
thanks, if I want to be really sure its right for a bunch of repeated objects, I sometimes create a wireframe of a box that is the scale of my texture and reference it when I use box mapping
User avatar
By greengreen
#384277
Funny thing, I was having this problem again, so I came back to this thread. Seems like I can toggle the "use override" check box on and then off, and then my materials are mapped in real scale. Otherwise I could not get it to work at all

It looks more like a smooth normal problem. Like i[…]

I had some very strong highlights in some material[…]

Daydreamer

Thanks everyone! I didn't want to use volumetrics […]

opening V5 files in v6

just installed latest version for Rhino V6 when I[…]