It is not possible to say, without more detailed information; it will be quickest & easiest to check, by looking at your actual C4D file -- please zip and send it to jeremy at nextlimit dot com.
Thanks -- I don't know the reason why (perhaps something to do with floating point precision vs. lens shift?), but if you change your camera's Focus Distance (i.e. Camera > Object > Focus Distance) to coincide with the ring (around 60cm, rather than 2000), it appears to fix the problem.
I don't know if its related, but the plugin doesn't recognize the camera target tags status (enabled/disabled) it sees it as enabled always, and also doesn't recognize if pitch is disabled. Its been this way for a long time though, just got used to it...
I'm not seeing this -- using any combination of Enabled/disabled and Pitch on/off in the Target Expression Tag, I'm not able to observe (except in one case, described below) the camera in Maxwell going out of sync with the Cinema camera.

The one case is: FIRE is rendering, the tag is disabled, the camera is moved (in a way it could not be, were the tag enabled), and the tag is then enabled; upon enabling the tag, the Cinema camera will jump into position, but this particular change is not being heard by the plugin, so it is necessary to scrub the timeline, or otherwise trigger a view update, at which point the FIRE view is again synchronized. I don't figure this is what you're referring to, though.

So, please let me know precisely how to reproduce the behavior to which you're referring.
By precise, I mean -- in my example, I will have added a target camera, a cube, a scene, and started rendering in FIRE, and found that it works fine. However, whenever I get a scene from you, it's far more complex than that, and there's no way to know what edge case you could be triggering. So, either you would need to send me a file, or tell me exactly how to build the scene structure you're working with.
I see what you mean, now -- it happens when you enable Camera > Object > Use Target Object. And yes, you should be able to use Camera > Object > Focus Object, instead of enabling Use Target Object. If you split to 4 viewports and move the camera or the object, you'll see that this will keep the focus on the object.

Probably the use of two "." in the file […]

Maxwell and Blender

An addon for Blender would be amazing. It would in[…]

Hey Patrik, thanks for the suggestion. 🙌🏼 Creams […]

Hi ki_cz, this is my attempt with another engine,[…]