By toybox
#362691
We've just recently updated to 2.7.20 from 2.6.10. We've been successfully using 2.6.10 with render layers in Maya but upon upgrading our configuration broke due to the unknown -l flag.

The Maya plugin version we were using when we were in Maxwell 2.6.10 was 2.6.23, and upon running running render.exe -r maxwell -help, it is clear that is a section on render layer/object parameters, and there is an -l flag.

Since then, we've updated the Maya plugin to version 2.7.8 in line with updating Maxwell, and running the -help yields only the -sel flag, which doesn't do what we need it to do.

Checking the documentation and there seems to be no reference to these flags as well.

I would just like to ask three things:

1. Have I missed something?
2. If I haven't, what is the latest Maya plugin version that still supported the -l feature?
3. And if this feature was indeed removed, why was this taken off? (That is much a real question as a rhetorical one - as a developer it's a bad trip because I have to write and debug set of breakout tools just to maintain the workflow we already have.)
User avatar
By Mihnea Balta
#362703
It was removed when we updated the flags to match mental ray. Autodesk renamed some flags and removed others when they released Maya 2008 and -l was among those removed. I haven't checked each flag in turn when I did this, I just took the common flags from the mental ray renderer description and added the Maxwell-specific flags. They probably made an error removing -l, because I see it's present in the Maya Software description file, and mental ray has it again starting with Maya 2009.

Anyway, I'll add it back for the next plug-in update. The last version which supports the flag is 2.6.27.
User avatar
By Mihnea Balta
#362706
Until we release the next update, you can replace the maxwellRender.xml file installed by the latest plug-in with the fixed version contained in this archive. The location of this file varies depending on the platform:

Windows: MAYA_DIRECTORY\bin\rendererDesc
OSX: MAYA_DIRECTORY/Maya.app/Contents/bin/rendererDesc and MAYA_DIRECTORY/Maya.app/Contents/MacOS/rendererDesc (it needs to be copied in both locations)
Linux: MAYA_DIRECTORY/bin/rendererDesc
By toybox
#362729
Hi Mihnea, thanks for your reply and solution. An hour after posting I created a workaround directly on our controller's config which is almost identical to your xml fix (eg editRenderLayerGlobals). Thanks for your effort. And if the -l flag omission was a mistake, pardon me if I sounded too whiny. I've been working intensively for two weeks developing Maxwell for use with Royal Render (coop, resume rendering, etc), and it's been edgy this past week.
Let's talk about Maxwell 5.2

This is really minor UI fix, but as we had a post […]

Clicking Recalc in Appearance or changing the S[…]

Hello, I agree with Jasper ... I still have this […]

Squared looking surfaces while rendering

That's the typical "shadow terminator problem[…]