#385848
Setup:
I'm running Maxwell 3.1.0.2 with 3ds Max plugin 3.1.5 on Windows 7 64-bit Enterprise.

Issue:
Currently, it's dropping the MXS file extension when exporting to MXS files. If I don't include a file extension, or a period at all for that matter (http://www.maxwellrender.com/forum/view ... 00&t=42810), it doesn't add ".mxs" to the file name.

If I include ".mxs" in the filename (i.e. "FILENAME.mxs"), it still drops the extension. I have to actually add a 2nd ".mxs" after the 1st (i.e. "FILENAME.mxs.mxs"). Then it strips out the 2nd ".mxs", leaving the 1st, resulting in a correct filename.

I didn't go so far as to clear out my 3ds Max user settings / profile yet. I wanted to post this in forum to see anyone else had this problem before I started breaking down my setup.

Thanks Next Limit!
#385860
Oddly enough, it doesn't appear to be doing it today. I didn't even reboot or anything, but it just stopped. When I posted this originally, I reset 3ds Max (through the UI) and made a new scene and it did exactly what I was talking about. Weird.... It actually acted like that for 3 days (ever since Monday).

I'll post back if the problem comes back or if I can figure what caused it. Thanks Next Limit!
#385868
I'll implement the request in the original thread (http://www.maxwellrender.com/forum/view ... 00&t=42810) for the next update. However, this thing with dropping the extension on export sounds really weird; it must be due to a combination of factors, because there's no code to explicitly remove the extension, but I can't see what that combination might be. It would be great if you can reproduce the bug, so I can fix it, as it sounds pretty nasty.
#385906
In the words of Bubs from Homestar Runner, "Well, I found the problem." Fortunately, no one tried to "cram-a-lam a Swiss Cake Roll into the disk drive". It was a lot cleaner than that :)

Turns out I had a period further up in the path. One of my parent folder names actually had the period. If no directory within the path has a period, then the plugin functions normally. When I tested this before, I didn't change the project folder, so my test export was writing to a directory with a period in the path.

Sorry for the false alarm. Thanks Mihnea!
#385996
Hi,

The version I've just uploaded to the early builds site (3.1.6) should always append the MXS extension to the scene file names, even if the file already has a different extension (e.g. if you had scene.ext, the final name will be scene.ext.mxs; the existing extension is not removed). Please give it a try and let me know if you still encounter problems.
#386001
It works beautifully! I tested it without an extension, with the ".mxs" extension, and with multiple dots / extensions and it dealt with all of it very gracefully.

Thank you so much Mihnea!

Hi there, after a texture tag has been assigned to[…]

Rhino6 Plugin / Rhino Crash

Having fun on my own thread here :) It appears tha[…]

The script will be useful and i think it is easy t[…]