User avatar
By bruno.sdi
#379851
Hi there,
When I apply maxwell grass to an object in 3dsMax2014 I can't see the red guides for the grass blades on the viewport... I used to see them perfectly in 3dsMax2011.
I'm sure it's something related to Max and not a bug from Maxwell Grass, but is there a way to fix this? Not something major but it was handy, specially when using clip masks for the grass areas.
Thanks!

Cheers
#379877
This is because the new viewport engine they've introduced in 2012 (called Nitrous) does not draw plug-in modifiers anymore. Lots of other things which were possible in the "legacy" viewport don't work from plug-ins anymore. The viewport part in Max is a mess anyway. Every few releases some guy at Autodesk decides the existing viewport code is crap (which is true), so he makes a grand design which is going to be awesome (which it won't), and implements some effect which games have had since 2001, and his manager is happy and they post about this on some blog. Then the process repeats. Sometimes they change the interfaces which the plug-ins have to use to draw stuff in the viewport, but that's not a huge problem for us, since we just adapt our code. Other times, like with this Nitrous thing, they forget they even had those features, so they don't add replacement interfaces, and we're no longer able to do things like draw grass.

I suspect there's some way of drawing stuff in the viewport from modifiers, because their hair modifier does it. However, it might not be available to plug-ins. We will look into this again soon, maybe we can find a hack or the magic API that the hair is using.

Hi there, after a texture tag has been assigned to[…]

Rhino6 Plugin / Rhino Crash

Having fun on my own thread here :) It appears tha[…]

The script will be useful and i think it is easy t[…]