Everything related to SDK.
By d76
#385067
Hello,
(seams like i am the only one writing to this forum recently :) shame on me..)

i am really glad to see py3.4 included in release, but i run into a problem with 3.1 (downloaded today):
Code: Select all
Extension: /Applications/Maxwell 3/extensions/MaterialModifiers.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MaxwellCloner.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MaxwellGrass.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MaxwellHair.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MaxwellMesher.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MaxwellParticles.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MaxwellProcedurals.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MaxwellScatter.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MaxwellSea.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MaxwellVolumetric.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MGrassH.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MGrassP.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/MWObjectAlembic.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/RFMeshes.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/RWMeshes.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/SubdivisionModifier.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/TiledTexture.osx.mxx incompatible with current SDK version
Extension: /Applications/Maxwell 3/extensions/WireframeTexture.osx.mxx incompatible with current SDK version
Traceback (most recent call last):
  File "/test_objects39-af32aee4-a739-11e4-8d1e-74d4358c8c86.py", line 961, in <module>
    main()
  File "/test_objects39-af32aee4-a739-11e4-8d1e-74d4358c8c86.py", line 891, in main
    particles(d, mxs)
  File "/test_objects39-af32aee4-a739-11e4-8d1e-74d4358c8c86.py", line 649, in particles
    params = ext.getExtensionData()
AttributeError: 'NoneType' object has no attribute 'getExtensionData'
and for verification:
Code: Select all
$ py
Python 3.4.1 (v3.4.1:c0e311e010fc, May 18 2014, 00:54:21) 
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import pymaxwell
>>> pymaxwell.getPyMaxwellVersion()
'3.0.9.4'
running the same code above in Pymaxwell.app crashes it instantly.. Mac OS X 10.9.4 if that matters.
seems like either extensions or pymaxwell were not updated to 3.1
User avatar
By Brany
#385072
The crash is our fault. There is a python version mismatch between pymaxwell Editor and the pymaxwell package the editor use. We will have to update the osx installer today. Meanwhile you can replace the line on the sys.path system variable where pymaxwell Editor points the pymaxwell package:

/Applications/Maxwell 3/Pymaxwell.app/Contents/MacOSX/../../../Libs/pymaxwell/python2.7

and change it to 2.6:

/Applications/Maxwell 3/Pymaxwell.app/Contents/MacOSX/../../../Libs/pymaxwell/python2.6


Regarding the extensions problem, it seems that you are using an old version of the pymaxwell python package. Maybe you have to copy the pymaxwell python package from the Maxwell 3 installer path to your python site-packages folder (usually /Library/Python/2.7/site-packages, depending on the python version you use), and replace the old one. Checking your sys.path variable in python you can find the pymaxwell module that python is loading:

(Console)
python
>> import sys
>> for i in sys.path:
>> print i
>>

The old pymaxwell package that python is loading must be in one of the paths in sys.path.


Hope it helps. I'll let you know when you can download the new installer for osx
User avatar
By Brany
#385075
pymaxwell 3.1 for python 3.4 you have in osx is an old beta version, so forget what I told you in the previous entry, both errors are due to a version mismatches in the osx installer. It only affects to pymaxwell editor and pymaxwell python package for python 3.4 (both in osx only).

As I said, we will update the osx installer today, I'll let you know!

Thanks, Luis, appreciated. It looks like industria[…]

That looks like a low bpc (bits per channel) norma[…]

Fully working plugin for C4D

When you will be working on it please try to keep […]

Let's talk about Maxwell 5.2

Is there any update regarding CPU engine ? Som[…]