Everything related to SDK.
#343832
hello.

I tried to compile 2.5.1 SDK with XCode 4.0 ( Mac OS X 10.6 ) for my plugin project. but It failed by liker ld error.
Code: Select all
// compiling for 32bit intel
Undefined symbols for architecture i386:
  "_Microseconds", referenced from:
      Ctimer::Ctick::getRandomSeed()     in libmxs.a(timer.o) ... 67 errors more...

// compiling for 64bit intel
Undefined symbols for architecture x86_64:
  "_Microseconds", referenced from:
      Ctimer::Ctick::getRandomSeed()     in libmxs.a(timer.o)
I googled, and it seems to be known problem of Mac OS X 10.6 environment.
I checked 'ranlib' for libmxs.a, and it showed "no symbols" message for each architectures ( ppc/i386/x86_64 ).
I tried some liker options, but no succeed.

anyone can compile SDK on OSX 10.6? Did I miss anything?

regards.

tg_jp
#344206
thank you for replying. It's help a lot.

I have linked with CoreService.framework, so now I linked with Foundation.framework and CoreService.framework. Still Linker Errors are remained, but its count is decreased. now I have 2 question.

1. Are there any other framework or external library I should link with? Should I link with additional libraries (png/tiff/imf/zip) for compiling?
2. A maxwelllights.h file is missing in SDK, but maxwelllights.cpp, it's not required?

regards.

tg_jp
#344213
Hi tg_jp,

1- Yes, linking with zlib is usually also required. Depending in what functionality you use from the SDK, you might also need to link with Cocoa or even libxml2. But as I said it depends on what functions of the sdk you are using.

2- Yes that's not needed, it's just an example of how to convert some of the non physical lights to geometry ones keeping similar behaviour.

Best regards,

nachob
Let's talk about Maxwell 5.2

We have planned a 5.1.2 patch for September, but[…]

Help with plastic/glass material

Tinted polycarbonate plastic works only in a Viewp[…]

4K Support not working

Oops. Sorry, I opened V4 not V5. The latter fits i[…]

Hi again dear customers, In the version we upload[…]