Everything related to Maxwell Render and General Stuff that doesn't fit in other categories

Have any of the Threadripper users noticed very slow pre-processing times with Maxwell rendering/Fire previews?

I installed Maxwell Studio v5 on some other machines ( M1 Mac, Intel Mac, Xeon Windows 8.1) and all the machines performed similarly with pre-processing and all the machines outperformed the Threadripper in pre-processing times with v5.

The Threadripper seems to stall at the "initializing data" stage --just before "preprocessing geometry". It sits there for a very long time and then it finally proceeds as normal.

Anyone else experiencing this?

Okay. I've done some benchmarks and examined both my processor and my memory and both appear to be hitting or exceeding their benchmarks, i.e. clocking as they should be. So, the hardware seems solid.

IMO, this implies that the issue is a software issue. Either Windows 10 or Maxwell Studio v5 is having an issue /a bug with the AMD Threadripper system that results in excessively long pre-processing times when rendering under v5.

(I don't appear to have any issues when rendering in Blender Cycles -- but then I don't know if that's a fair comparison.)

So, yeah, it would be helpful to know if others are experiencing longer pre-processing times on their Threadripper machines with v5.
I can tell you - from my experience with specific intel CPU - that had a special "turbo boost" intel utility that was supposed to boost performance. well, for Maxwell it did the opposite, making it use the CPU as low as 1-5% instead of 100%. After I closed it, Maxwell ran as usual at 100%. So it makes sense to check if you have some sort of AMD boosting app that may cause Maxwell to run slower.

Thank you. I'm not finding any AMD processes running in the background. Everything is operating at defaults --no overclocking. I've not installed any special software related to the processor. All the drivers are up to date --including GPU. The bios is up to date.

The problem seems to be specific to "initializing data" in the Maxwell Render dialogue. it occurs with every scene including the sample scenes supplied by Maxwell Studio. It happens both when using the CPU and when using the GPU render engines. Essentially, it just seems to stall at that stage of the render startup process. Then after some time it resumes as normal. I don't know what it's doing in the "initializing data" phase but obviously there's something slowing it down or interfering with it such that it slows down a great deal. (As mentioned, this only occurs on my Windows 10 Threadripper machine.)

I don't see anything unusual opening in the background when I hit the render button. So, there doesn't seem to be a background process that's interfering with data initialization for the renderer.

I turned the real time protection off; then I turned the virus protection off all together; then I placed the Maxwell programs in the "exclusions" dialogue so the virus program would not examine them at all. Nothing helped, i.e. the renderer still slows down/stalls at the "initializing data" phase.

I'll also point out that the renderer does take longer to open up in general (I get a big white window that remains for a while before the renderer opens). This behavior doesn't occur on my other non-Windows 10, non-Threadripper machines. Come to think of it . . . I think all the Maxwell programs take a slight bit longer to open on this machine than on my other machines. Regarding the GPU: I've used the same nVidia GPU for some time now --and in other machines too so I don't think that's an issue.

Basically, I still want to say that it seems like a bug --either in the Maxwell Studio v5 software or with a Windows 10 process that "initializing data" relies on.

Thank you. Yes. Here are the specs:

Windows 10 Pro
Asus Prime x399-a motherboard
Nvidia 1080 GPU
64 GB RAM (no overclocking)
AMD Ryzen Threadripper x1950 (no overclocking)
NVMe M.2 drives (Samsung 970 Pro)

All the drivers and the bios are up to date. And Windows 10 is up to date. (And I'm not using any specialized software to control anything, i.e. no Asus or AMD utilities or anything -- it's just Windows 10 running.)

Is that helpful?

And a Wacom tablet, a bluetooth keyboard, a USB Logitech wheel mouse, and a USB 3d Connexion mouse as input devices --if any of that info helps. :)

But, I use (have used) these devices on other computers running Maxwell Studio so I don't think they're an issue.

Thanks again!
The Threadripper 1000 Series and the 2000 Series suffers from memory latency due to the Chip configuration layout.

They both work way better on Linux istances with performance boost over 20-30% compared to Windows counterpart.

They solved partially the performance gap within the latest windows 10 Pro updates released during the last year.


1) 64 GB of ram are good enough. But keeping them stock from BIOS isn't generaly a good idea.

Maybe you've a 3200 Mhz RAM, but they're settled up in the BIOS to run much slower.
Check frequency on your ram stick and the timing. Modify them inside the BIOS.
If they run 1333Mhz and you can setup them to 3200 Mhz you will notice immediately a performance Boost.

2) Threadripper and generally RYZEN platform love higher Memory Frequency.

The safe spot for series 1000 and Series 2000 is 3200 Mhz Ram speed
The safe spot for Series 3000 is 3600 Mhz Ram speed

3) Ram speed matter, but timing too. Choose always Ram with first timing digit equal or lower then 16.

4) I noticed Maxwell Render, since V4, start always MAXWELL STUDIO and MAXWELL RENDER with a very low priority within Windows Task MANAGER.
i always open task manager (CTRL + ALT + CANC) and modify the priority of maxwell render to Normal. That give a boost to your render by a small %.

5) Seems stupid, but a very high quality PSU could impact positively how your system work. On all my Threadripper Workstations i always use Corsair 80+ or 90+ Platinum or Gold full modular PSU.

6) Check if your Motherboard support a 2990WX Threadripper CPU. I've one workstation based upon this CPU and work very well, isnt comparable to a 3990x but without changing completely all your build, will give you back a Huge boost performance even the latest M1 apple cpu can't compete on High multythread rendering workflow.
Problem solved. (And it's not a hardware issue. :D )

Turns out that I needed to give "Studio.exe" administrator privileges on Windows 10 Pro. It's a bit annoying having to tell it to open in administrator mode every time I open the program but it solved the problem -- so I'm happy. (If you're experiencing this problem as well: Right click on "studio.exe" and on the compatibility tab tell it to "run as administrator" and click apply.) Solves the slow pre-processing problem completely.

Maxwell Render is now rendering quite fast on my Threadripper machine with no stalling or hang-ups. Yippie! :D

I tested this a few times by turning administrator privileges on and off and each time it was off the "initializing data" stall problem returned. Please note that giving studio.exe administrator privilege's on Windows 10 Pro is not the same as running Studio in "compatibility mode --(Windows 8.) I tried that as well and it didn't solve the problem but it introduced other problems --so avoid doing that.

If anyone knows how you can open a program with administrator priviliges always (and not get the annoying confirmation pop-up) please let me know. Maybe there's a switch you use or something.

So, I learned a lot with this exercise in frustration: I downloaded some utilities to take a look at things; did a bunch of benchmarks and tests; my memory is good on the Threadripper; latency is as good as on my Xeon machine; Threadripper hardware is good and running very fast. I can vouch for the system now --it's fast.

It would be great if in the next release of Maxwell Studio v5 that "administrator privileges" requirement on Windows 10 Pro issue could be worked out. --Or, maybe it's just my machine, i.e. user error. Probably is . . . I probably need to adjust some security settings or something --stuff that only programmers would know! :lol:

Thanks again for the input/helpful suggestions to those who replied to this post!
No. of GPU cards and speed

from my test with benchwell, AMD ryzen 9 vs 3060 G[…]

thought I was answering you on my latest post, but[…]

Hi friends, When I buy Maxwell 5 studio, can I tha[…]

Maxwell | Bundle

Hi, I noticed an email today that offers customer[…]