Btw, I tried launching CommandLine version of Cinema and this is what I got. Perhaps slightly more verbose:
Code: Select all
Application start      : 10/07/15 at 21:45:39
Executable             : 64 Bit
Version / Build        : 17.032 / RB139719
Debugger               : not available
Memory model           : release
Startup path           : file:///Applications/MAXON/CINEMA 4D R17
Application path       : file:///Applications/MAXON/CINEMA 4D R17/Commandline.app
Application executable : file:///Applications/MAXON/CINEMA 4D R17/Commandline.app/Contents/MacOS/Commandline
Resource path          : file:///Applications/MAXON/CINEMA 4D R17/resource
Module path(s)         : file:///Applications/MAXON/CINEMA 4D R17/modules
Temporary path         : file:///var/folders/cn/8t3y5cpx11q4dl1x9lj62gq00000gn/T
Prefs path             : file:///Users/bjorn/Library/Preferences/MAXON/CINEMA 4D R17_89538A46
Global Prefs path      : file:///Users/bjorn/Library/Preferences/MAXON
OS version             : OS X 10.11.0
Processor              : 2(4)x Intel Core i7 CPU M 620
Computer name          : Morris
Thread Count           : 4
Cpu Speed (MHz)        : 2660.000
Application Type       : Modular
Command line arguments : none

Loading file:///Applications/MAXON/CINEMA 4D R17/modules/c4dplugin.xlib with module(s) net.maxon.c4d.c4dplugin
Loading file:///Applications/MAXON/CINEMA 4D R17/modules/crashhandler.module.xlib with module(s) net.maxon.crashhandler
Loading file:///Applications/MAXON/CINEMA 4D R17/modules/crypt.module.xlib with module(s) net.maxon.crypt
Loading file:///Applications/MAXON/CINEMA 4D R17/modules/image.module.xlib with module(s) net.maxon.image
Loading file:///Applications/MAXON/CINEMA 4D R17/modules/mesh.module.xlib with module(s) net.maxon.mesh
Loading file:///Applications/MAXON/CINEMA 4D R17/modules/misc.module.xlib with module(s) net.maxon.misc
Loading file:///Applications/MAXON/CINEMA 4D R17/modules/network.module.xlib with module(s) net.maxon.network
Loading file:///Applications/MAXON/CINEMA 4D R17/modules/triangulation.module.xlib with module(s) net.maxon.triangulation

Error: plugin (libmx_common.dylib) doesn't return c4d_main ptr. symbol 'c4d_main' is missing. error: dlsym(0x7fbb0b62ac70, c4d_main): symbol not found [osx_dll.cpp(121)]

Loading Maxwell for Cinema 4D version 3.2.0, Oct  2 2015 10:34:08 (engine, sdk

Maxwell: Unable to find Maxwell Render!

Maxwell: Unable to find Maxwell Studio!

Maxwell: Unable to find Maxwell Mxed!

Maxwell: Failed to load tbb.

It's funny how it says It cannot find Maxwell render etc. now when I check the folder, it's empty! Something must have gone wrong in the last update or something. I'll re-install right away and get back.
To be precise, the weird part is in the log you posted above, where we see Cinema trying to load libmx_common.dylib as though it is a Cinema plugin. This fails, because that is the Maxwell SDK library, which knows nothing about Cinema, and which therefore has no Cinema plugin entry function (i.e. c4d_main). I'm still trying to figure out how to convince Cinema to try to load it that way on my machine. libmx_common.dylib should be located a few folders deep in the plugin directory (plugins/<maxwell>/ext/osx/libmx_common.dylib), and Cinema should know nothing about it.
Okay, turns out it is not so weird, I just hadn't realized that by saying you launched the command line version, you actually ran the version of Cinema called "CommandLine". Running that, I see Cinema trying to load libmx_common.dylib the same as you posted. But still no crashes.

So far my only option was to ungroup (my group wa[…]

Thanks Miguel I know 5.2+ is a big development hi[…]

SketchUp 2021 Update

Hi Alberto, Many thanks for taking the time to ma[…]

Let's talk about Maxwell 5.2

Features are closed and tested, we are testing p[…]