By darinh
#278392
I need a way to remove all the attributes that the Maxwell plugin creates in Maya, every single geo node gets an attribute as well as the camera and the renderglobals. At my work I'm currently testing Maxwell on XP64 to see it's usefulness in production work, but do most of my rendering on Linux in Mentalray for deadlines sake. I've had scene files that I didn't even use with Maxwell (but the Plugin creates the attributes anyway) that I've brought into Linux and have refused to render with MentalRay. After trying to figure out the issue ,on a whim I went through and cleaned all the Maxwell attributes from each node by hand in an .ma file and magically the problems were gone.
Im not a script writer but I'm sure there's a fairly easy way to remove these attributes automatically, better still if the plugin didn't create the nodes unless you actually wanted to render with Maxwell!. What's more frustrating is that once the nodes are created the plugin refuses to unload and automaticaly loads itself up even if you uncheck autoload.

I'm hoping NL might have some insight into this problem or have some suggestion of a solution, my only current one is to uninstall the plugin completely from Maya.
User avatar
By Mihnea Balta
#278411
The latest plug-in only creates those attributes when you set them to a non-default value. However, even if they're present, they don't interact with other renderers in any way.

If you don't have any Maxwell materials in your scene, your problem is probably the maxwellRenderOptions node. Run the command "delete maxwellRenderOptions", save the scene and it should load without problems on systems where the Maxwell plug-in is not installed. Another option is to use .mb files, since only .ma files have problems with plug-in nodes. Of course, if you have Maxwell materials in the scene, you need to delete them too. Please note that opening the render globals window with Maxwell as the active renderer, or setting Maxwell as the active renderer re-creates the options node.

The problem with unloading the plug-in results from a Maya limitation. You will see that it plagues other plug-ins too - for example, try unloading the mental ray plug-in after you've rendered once with it, it won't be possible. Maya will store the list of active plug-ins in the .ma or .mb file and attempt to load them next time you open the scene, which is why the plug-in comes back even if you uncheck "autoload". One solution (after deleting the render options node) is to open the .ma file and remove the line which starts with "requires maxwell". Another solution is to make the plug-in unavailable (by uninstalling it or renaming maxwell.mll to something else), open the scene and save it again (this should work for .mb files too).

Anyway, the key should be deleting the render options node. Even if the scene says it needs the Maxwell plug-in and it's not present, it will still work correctly if that options node is gone. Please tell me if this solution worked for you, otherwise we'll investigate further.
Multiple surfaces on object

I guess you are asking about chanching a material […]

New Develepments for 5.2?

Some areas that need addressing One why can't we[…]

..... help please ..... :mrgreen:

can't open it, can't open the fbx I got from a fri[…]