Everything related to Maxwell Render and general stuff that doesn't fit in other categories.
To install maxwellrender on MacOSX go to this post:


and to find some command line basics in conjunctoin to the manual, go to this post, scroll down and find my post (9th from the top):


or download a test mxs scene directly from here:


Have fun.. NL says it will release a few MaxOSX goodies next week!! :D
User avatar
By ingo
Many thanks for the test scene, i was a bit bored by rendering the caca scene over and over :D Can you say how many polygons the car has ?
User avatar
By noseman
sorry ingo I just saw your question, actually I have no idea. But I think that you can see it if you go to applications/maxwell/output/maxwell.log open it with textedit and it gives you info about the scene that it renderd last.

today they say we will have something.... at least an update!

By Nigel Baker
Hello Noseman,

Can you please tell me how to open your .mxs file
I have dropped it on the LW8 icon the Maxwell Icon but to no avail.

Please advise.
User avatar
By noseman
you can't "open" the mxs file, you can just render it.
The specific file was made with a previous verion of Maxwellrender so there is a chance you can't even render it.

First make sure you have installed Maxwellrender correctly (follow the posts about this problem) and then use you own LW plugin to make a new 3D scene.

By Nicolas Rivera
Hello noseman and nigel, i have done 1 image that worked ok in osx using the 3ds2mxl plugin for sketchup in virtual pc.

my path is this:

/Applications/maxwell.app/Contents/MacOS/mxcl -mxs:/Users/nicolasrivera/Desktop/sample2.mxs -d -mxi:w,/Users/nicolasrivera/Desktop/sample.mxi-res:640x480 -s:20 -t:480 -q:normal -th:1 -o:/Users/nicolasrivera/Desktop/sample2.tga

and it worked nicely, but what is the line code to set the number of bounces i want??? i cant find it anywhere???

By Nigel Baker
Hello Nicolas,

I too am a SketchUp user, just recently.
This point of yours interests me, could you explain some more about it to me. Are you using MAxwell R to output your files directly from SktechUp?

By Nicolas Rivera
hi, export 3ds from sketchup, import it to 3ds2mxl, this lconverts the 3ds to maxwell format, them just put it the mxl file in the desktop and run the command line from the terminal.

By Nigel Baker
Hello Nicolas,

Sorry, did not realise that 3Dmax is part of this work around.
But thanks for the reply. It will be very interesting when Maxwell is able to output directly through SketchUp.
Any chance of you posting an image that you did from SketchUp, please.

Thanks again Nicolas, all the best. :wink:
User avatar
By noseman
There are properties that you can't set from the command line (yet?), amongst them are the bounces :cry: . You can set bounces from the SW you created the mxs file.
By Nicolas Rivera
Hi Nigel and Noseman. 3dmax is not part of this at all. the 3ds is the extension i'm exporting the sketchup madel to. (.3ds) :lol:
By digitaluka
Nicolas Rivera wrote: my path is this:

/Applications/maxwell.app/Contents/MacOS/mxcl -mxs:/Users/nicolasrivera/Desktop/sample2.mxs -d -mxi:w,/Users/nicolasrivera/Desktop/sample.mxi-res:640x480 -s:20 -t:480 -q:normal -th:1 -o:/Users/nicolasrivera/Desktop/sample2.tga

Hi Nicolas
Just to let you know your post really helped me in figuring out all these path names and command lines. I am now rendering my pic with 4 threads and hopefully it will be saved as a tga file:) perhaps I will post it in the galley?

User avatar
By noseman
You should all know that M~R saves in the TGA file every once in a while. You can open that file at anytime during rendering and save it with another name. You can save the rendering progress that way.
There is no need to wait for M~R to finish the rendering.
As a matter of mact M~R never actually "finishes" any rendering. You just stop it when you are happy with the given result. Sample level 25 has never been reached from anybody in this lifetime!!

It looks more like a smooth normal problem. Like i[…]

I had some very strong highlights in some material[…]


Thanks everyone! I didn't want to use volumetrics […]

opening V5 files in v6

just installed latest version for Rhino V6 when I[…]