All posts related to V2
#367427
Hi, guys!
New Maxwell user here, so please excuse my noobyness.

One thing i would like to do is remove all depth of field effects for a smallish model in working on. Having a think, this is what i did: i created the camera, and using the Create -> Measuring Tools -> Distance Tools, i measured from the center of the cam to the center of the model (cunningly parented the locator shape to cam to save time when moving it), then put this distance in the Maxwell Render section in the camera's attributes. [Is this the best way to focus? If i dont do this, the render is miles out of focus].


Would the best way to remove DOF be to increase the FStop, then lower the ISO / shutter speed to brighten up the image? (I get a lot of grain doing that, but i can work on that externally). How about camera zoom? Better to place the camera further away and zoom in, or closer?

Secondly, im having a problem with FIRE. It used to work, but when i press the yellow button now, i get a red error in Maya saying " .... maxwellregisterShelf.mel line 583: Objects name 'MaxwellFIRE' is not unique". I have tried reinstalling the plugin, unloading it from Maya, but i just wont work. Any ideas?

Thank you in advance for all your help.
#367430
aburley wrote: One thing i would like to do is remove all depth of field effects for a smallish model in working on. Having a think, this is what i did: i created the camera, and using the Create -> Measuring Tools -> Distance Tools, i measured from the center of the cam to the center of the model (cunningly parented the locator shape to cam to save time when moving it), then put this distance in the Maxwell Render section in the camera's attributes. [Is this the best way to focus? If i dont do this, the render is miles out of focus].
There are several ways to achieve this:
- for a camera with an aim locator, the aim locator is the focus point
- if you select an object and then press F, that object will be in focus (or, more precisely, its center). This works even if the camera doesn't have an aim locator.
- there's a "focus to" button on the Maxwell shelf. Select the camera you wish to focus, select the object, then press that button. If manual focus distance is off, it will move the aim locator (or orbit center). If manual focus distance is on, it will modify the focus distance directly.
- you can rig a distance measure to control the focus distance. Make sure you constrain it to always be perpendicular to the camera plane, because that's how focus distance is measured. I think there are a few examples on the Maya subforum from people who have done this already.
- finally, the manual method which you've already employed
aburley wrote: Would the best way to remove DOF be to increase the FStop, then lower the ISO / shutter speed to brighten up the image? (I get a lot of grain doing that, but i can work on that externally).
This works almost like in a real camera: a high f-number will give you a deep field, so more things will be in focus, but it lower the exposure, since less light reaches the film. Increase the ISO or the exposure time to compensate. The only difference from a real camera is that increasing the ISO does not introduce noise. The noise in a real sensor comes from electronic amplification of the signal, which is imperfect; Maxwell does not have that problem. The grain you're seeing does not come from high ISO, it must be something different.
aburley wrote: How about camera zoom? Better to place the camera further away and zoom in, or closer?
That decision should be taken in the same way as when shooting with a real lens. For example, using different focal lengths will affect vignetting (but you can tell Maxwell to do devignetting in the Simulens section of the render globals).
aburley wrote: Secondly, im having a problem with FIRE. It used to work, but when i press the yellow button now, i get a red error in Maya saying " .... maxwellregisterShelf.mel line 583: Objects name 'MaxwellFIRE' is not unique". I have tried reinstalling the plugin, unloading it from Maya, but i just wont work. Any ideas?
Does this happen the first time you press the button in a Maya session? The script editor should contain more error messages before the line about the name being duplicated. Could you paste the entire contents of the script log, please?
#367434
Thank you for all your tips - im well on my way now!

These are the errors i get with FIRE

Scenario - my scene is loaded:

Press the FIRE button:
Code: Select all
maxwellGetIsolatedObjects("persp");
// Error: file: C:/Program Files/Autodesk/Maya2014/scripts/others/maxwellRegisterShelf.mel line 466: No object matches name:  // 
Press the FIRE button a second time:
Code: Select all
maxwellOpenInteractiveViewport;
// Error: file: C:/Program Files/Autodesk/Maya2014/scripts/others/maxwellRegisterShelf.mel line 583: Object's name 'MaxwellFIRE' is not unique. // 
Scenario - Freshly opened Maya 2014, nothing loaded:
Contents of script editor:
Code: Select all
file -f -new;
// Warning: file: C:/Program Files/Autodesk/Maya2014/scripts/startup/rememberViewportSettings.mel line 43: Active stereo does not work with Aero enabled. Active stereo has been disabled. // 
// untitled // 
commandPort -securityWarning -name commandportDefault;
// AbcImport v1.0 using Alembic 1.1.2 (built Oct 22 2012 17:06:34)
// AbcExport v1.0 using Alembic 1.1.2 (built Oct 22 2012 17:06:34)
updateRendererUI;
Press the FIRE button,
Code: Select all
maxwellOpenInteractiveViewport;
// Error: line 1: Cannot find procedure "maxwellOpenInteractiveViewport". // 
#367437
Please download this file: http://maxwell.griffinlair.com/maxwellRegisterShelf.mel and overwrite the existing file in C:\Program Files\Autodesk\Maya2014\scripts\others. Restart Maya and try to open FIRE. Right before the error message, you should see some lines like this:
Code: Select all
Viewport: 'maxwellViewport1'
Camera transform: 'persp'
Camera shape: 'perspShape'
Could you please paste those lines here for me? I'm guessing the last one will say '' instead of 'perspShape', but I need all 3 to try to figure out what's going on.
#367457
Hi, i have done exactly as you asked, and all i see is this:
Code: Select all
file -f -new;
// Warning: file: C:/Program Files/Autodesk/Maya2014/scripts/startup/rememberViewportSettings.mel line 43: Active stereo does not work with Aero enabled. Active stereo has been disabled. // 
// untitled // 
commandPort -securityWarning -name commandportDefault;
// AbcImport v1.0 using Alembic 1.1.2 (built Oct 22 2012 17:06:34)
// AbcExport v1.0 using Alembic 1.1.2 (built Oct 22 2012 17:06:34)
updateRendererUI;
maxwellOpenInteractiveViewport;
// Error: line 1: Cannot find procedure "maxwellOpenInteractiveViewport". // 

EDIT:
Restarted my PC, now i see what you are looking for:
Code: Select all
file -f -new;
// Warning: file: C:/Program Files/Autodesk/Maya2014/scripts/startup/rememberViewportSettings.mel line 43: Active stereo does not work with Aero enabled. Active stereo has been disabled. // 
// untitled // 
commandPort -securityWarning -name commandportDefault;
// AbcImport v1.0 using Alembic 1.1.2 (built Oct 22 2012 17:06:34)
// AbcExport v1.0 using Alembic 1.1.2 (built Oct 22 2012 17:06:34)
updateRendererUI;
maxwellAbout;
// Error: line 1: Cannot find procedure "maxwellAbout". // 
maxwellAbout;
// Error: line 1: Cannot find procedure "maxwellAbout". // 
// Maxwell: listing extensions:
// Maxwell: texture extensions:
// Maxwell: found 0 texture extension(s).
// Maxwell: geometry modifier extensions:
//    "MaxwellCloner"
//    "MaxwellGrass"
// Maxwell: found 2 geometry modifier extension(s).
// Maxwell: geometry loader extensions:
//    "MaxwellMesher"
//    "RFMeshes"
//    "RWMeshes"
// Maxwell: found 3 geometry loader extension(s).
// Maxwell: procedural geometry extensions:
//    "MaxwellHair"
//    "MaxwellParticles"
//    "MGrassH"
//    "MGrassP"
// Maxwell: found 4 procedural geometry extension(s).
// Maxwell: sky extensions:
// Maxwell: found 0 sky extension(s).
// Maxwell: scene modifier extensions:
// Maxwell: found 0 scene modifier extension(s).
// Maxwell: found 9 extension(s) in total.
updateRendererUI;
maxwellOpenInteractiveViewport;
maxwellGetIsolatedObjects("persp");
Viewport: 'maxwellViewport1'
Camera transform: 'persp'
Camera shape: 'perspShape'
Viewport: 'maxwellViewport1'
Camera transform: 'persp'
Camera shape: 'perspShape'
Viewport: 'maxwellViewport1'
Camera transform: 'persp'
Camera shape: 'perspShape'
// Warning: file: C:/Program Files/Autodesk/Maya2014/scripts/others/maxwellRegisterShelf.mel line 648: Panel size cannot accommodate all requested Heads Up Display elements. // 
#367541
Hi, i found the problem - for some reason, Maya wasnt remembering to keep the Auto Load box for maxwell.mel ticked when i reopened it. Every time i open Maya, i have to tick the Load box. Having said that, it is doing so now, and Maxwell is working great. I guess i should have checked that more often before posting!

Thanks again for taking time in helping me, and sorry for any bother.

A followup question Miguel, I think the following […]

Materials Library not working

Yeah. We have changed to a new website on a new se[…]

SketchUp 2021 Update

Hi CDRA, SketchUp 2021 have changed the sdk and mo[…]

Let's talk about Maxwell 5.2

Good news, thank you Jochen