All posts related to V2
By Polyxo
#365147
Hi All,
for about two months or so I have a huge problem with maxwell.exe (the framebuffer).

It can no more get opened in a way that it runs stable. The GUI appears but I get the
cross-shaped precision-picker and not the normal arrow (that is so using any shortcut or when
clicking on the .exe directly).
Nothing can be done in the GUI, when clicking around the windows-popup appears which
tells that the application doesn't react. One can not start a render but only close the app.

When pressing Render from Rhino the Buffer appears too and this time the engine even renders -
one can see that all three files are written.
But the image doesn't populate the buffer and all readouts, progress-bars and so on are dead as well.
And again trying to use the GUI leads to the "app doesn't react"-message. When leaving the GUI alone one
should be able to render normally.

The strange thing is that this happens 4 out of 5 times, sometimes however everything is normal.
But I can't see any patterns... Yesterday all was fine when running tons of other apps besides Mw, today
I run into this error with a fresh windows-session and no other program open.

I already disabled Antivirus to see if that had an impact and also did a clean new install of Maxwell and
Plugin. At this point I have no idea what more I could do.

Is this problem known or is there some sort of debug-tool available?
I'm on Win7 64, the Software ran on the same machine for 2 years.
It always ran with priority set to low (default).

Thanks for any input!

Holger
User avatar
By macray
#365149
Did you try to completely remove and reinstall Maxwell? (make sure to secure your materials, .ior, .ies or whatever else you might have saved in the Maxwell folder before removing it.)

eventually download the latest version again to make sure you're running the most up to date version of Maxwell and the Plugin.




ne andere Möglichkeit fällt mir grade nicht ein und ich nutze kein rhino.
By Polyxo
#365151
Thanks macray,
yup - as stated - I've done that already. This did not change anything.
The problem should be independent from Rhino, I could also trigger this sort of undesired "silent mode" from Studio.

While posting I'm running a render without issues - I don't get it.
By JDHill
#365154
Though you may have reinstalled, just make absolutely sure that in doing so, you have manually verified that every component in Next Limit/Maxwell 2 has been completely deleted from the machine before the reinstallation. You should also use a fresh download of the application, to rule out the possibility of corruption in the specific installer you are using. Maxwell relies on the VC++ 2008 SP1 redistributables (x86, x64); these are automatically installed by the Maxwell installer, but to rule out any possible failure there, you might download and reinstall them manually. Lastly, I am not sure, but it may also be that Qt will use the graphics card for UI in some cases, so check on the possibility of updating or using different display drivers.

The problem with all these suggestions, though, is that you are focused only on maxwell.exe. You briefly mentioned Studio, but is studio.exe actually working flawlessly? Reason being, studio.exe uses the same physical libraries, so problems with one should usually be seen in the other as well. You should probably do some testing to see if you are able to observe any of the same problems when using studio.exe.

Anyway, the point is that this does not seem very much like hardware failure, since you say it happens before you ever begin rendering, and that when it does not happen, you are able to render just fine. If so, and if we can rule out the possibility of corrupt Maxwell components and display driver issues, then you would want to start looking at other software components. You might begin by disabling or uninstalling any global 3rd-party tools (window theming apps, etc), and then eventually, you might also try using sfc /scannow, to verify the health of OS components.
By Polyxo
#365163
Thanks JD,
that's quite a list but I think I've considered most of this already.
I used Revo-Uninstaller, which scans the Registry and also deletes app-specific remains on the C-Drive.
After de-installation I rebooted and installed freshly downloaded installers (no upgrade but the full package).

Qt: Studio seems not to have any issues - also other programs I have using qt-framework for their GUI show no problems.
Also the Framebuffer looks perfectly fine there's no visual defects whatsoever - it just acts like a frozen programs when that error occurs.

Also I ran the sfc-scan some weeks ago.I recall that it said that it could not access some data but that's apparently normal.

There's no theming app in place but I tried disableing my Monitor-Manager (Display-Fusion) as well as my Antivirus Software
(I use both for years already). No avail.
Still - I should go on looking in this global-tools area but as my machine is quite customized I hoped that there was debug-tool
available which helps narrowing possible conflicts down.

My latest suspicion is Listary, a nifty file-browsing addon for Explorer. I've started using it some months ago.
That said: Currently Listary is running and Maxwell behaves fine as well.

So from your list there's still the display-driver and the C++redistributable - I'll check this out.

Thanks again!
By Polyxo
#366849
Puh...
after several fresh installations of Maxwell (which were totally in vain) it seems that I finally
isolated the problem...

Process Hacker, a nice open source replacement for the Task Manager seems to be the cause,
to be precise one option of that tool called "cycle based CPU usage". I can not remember having checked
this but one should either use something else or untick that box. No more MR-freezing thus far.

Image

I'm writing a converter for curves from Houdini to[…]

Free HDRIs for everyone

Thank you!

Hi Guys... Just updated Rhino to Maxwell plugin V[…]

SketchUp 2021 Update

Hi there! Sorry, it is the obligatory post relat[…]